《ACM程序设计》书中题目 X - 24 打电话

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

- Emergency 911
- Alice 97 625 999
- Bob 91 12 54 26
In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000.Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES


       这道题的基本题意为给你一个通讯录,然后拨打电话,如果要拨打的电话前几位通讯录中存在,那么将拨打这个电话,而不是那个电话号更长的那个。

       基本思路为先将给出的手机号进行排序,然后在后面的手机号中查找前面的手机号,如果找到则输出NO,如果没有子手机号则输出YES。


源代码如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
int t,n,i,j,k,h;
string b;
vector<string>a;
cin>>t;
while(t--)
{ a.clear();
 cin>>n;
 for(i=0;i<n;++i)
  { cin>>b;
         a.push_back(b);
  }
 sort(a.begin(),a.end());
 h=1;
 for(i=0;i<n-1;++i)
  { if(a[i+1].find(a[i])==0)
    { h=0;
      break;
    }
  }
     if(h)cout<<"YES"<<endl;
     else cout<<"NO"<<endl;
}

     刚开始查找的时候用的二重循环,一直超时,后改为一重循环就AC了。


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值