Phone List 【字典树 字符串集中 一个字符串是否为另一个的字符串的前缀】

Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
Input
The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES

字典树
代码

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXN = 100000+10;
int ch[MAXN][40];
int val[MAXN];
int word[MAXN];
int sz;
int flag;
void init(){
    memset(ch[0],0,sizeof(ch[0]));
    memset(val,0,sizeof(val));
    memset(word,0,sizeof(word));
    sz=1;
}
int idx(char c) {return c-'0';}
void Insert(char *s){
    int i,j,len=strlen(s);
    int u=0;
    for(i=0;i<len;i++){
        int c=idx(s[i]);
        if(!ch[u][c]){
            memset(ch[sz],0,sizeof(ch[sz]));
            val[sz]=0;
            ch[u][c]=sz++;
        }
        u=ch[u][c];
        word[u]++;
    }
    val[u]=1;
}
void Find(char *s){
    int i,j,len=strlen(s);
    int u=0;
    for(i=0;i<len;i++){
        int c=idx(s[i]);
        if(val[u]&&word[u]>=2){//如果当前节点为关键节点并且其是两个字符串以上的前缀,如果只是>=1的有可能是自身的字符串;
            flag=1; break;
        }
        u=ch[u][c];
    }
}
char str[10000+10][10+5];
int main()
{
    int t;cin>>t;
    while(t--){
        flag=0;init();
        int n;cin>>n;
        for(int i=0;i<n;i++){
            scanf("%s",str[i]);
            Insert(str[i]);
        }
        for(int i=0;i<n;i++){
            Find(str[i]);
            if(flag) break;
        }
        puts(!flag?"YES":"NO");
    }
    return 0;
}

还有另一种想法

int find(char *s)  
{  
   int i, j, l = strlen(s);  
   int u = 0;  
   for(i = 0; i < l; i++)  
   {  
       int c = idx(s[i]);  
       u = ch[u][c];  
       if(word[u] == 1)//找到可确定前缀   
       return 1;  
   }   
   return 0;//找不到可确定前缀   
}  
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值