POJ 1328 Radar Installation 贪心

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28996 Accepted: 6352

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

 

 

 题意:有一个坐标轴 在X轴上方是海 下方是陆地 X轴是海岸线,海上有N个小岛,现在要在海岸线上安装雷达,

雷达的覆盖范围是一个以R为半径的圆,请用最少的雷达覆盖所有的小岛;当无法覆盖时 输出-1

 

思路:算出 每个小岛能被覆盖的雷达的圆心,即以小岛为圆心 R为半径 作圆,该圆与X轴的交点:

左交点为x-sqrt(R*R-y*y); 右交点为x+sqrt(R*R-y*y);

按照 左交点 排序,如果i点的左交点在 当前雷达的右边 则需安装一个新雷达,更新雷达

否则 如果 i点的右交点也在当前雷达的左边 则把当前雷达的圆心更新为该点的右交点;

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
const int N = 1001;
struct SCOPE
{
	double l,r;
}scope[N];
bool cmp(SCOPE a, SCOPE b)
{
	return a.l<b.l;
}
int main()
{
	int n,R,i,Case=0;
	double x,y,t;
	while(scanf("%d %d", &n, &R),(n+R))
	{
		int ans=1;
		for(i=0; i<n; i++)
		{
			scanf("%lf %lf", &x, &y);
			scope[i].l = x - sqrt(R*R-y*y);
			scope[i].r = x + sqrt(R*R-y*y);
			if(y>R || R<=0 || y<0) ans=-1;
		}
		sort(scope, scope+n,cmp);
		t = scope[0].r;
		for(i=1; i<n && ans!=-1; i++)
		if(scope[i].l>t)
		{
			ans++;
			t = scope[i].r;
		}
		else if(scope[i].r<t) t=scope[i].r;
		printf("Case %d: %d\n",++Case, ans);
	}
	return 0;
}


 

调试的时候 把N改小了 结果忘了改回去、RE一次

忘了考虑点的左右交点都在 t左边的情况 WA两次  ORZ,太粗心了;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值