链接:https://www.luogu.org/problemnew/show/P1980
题目:
题目描述
试计算在区间 11 到 nn的所有整数中,数字x(0 ≤ x ≤ 9)x(0≤x≤9)共出现了多少次?例如,在 11到1111中,即在 1,2,3,4,5,6,7,8,9,10,111,2,3,4,5,6,7,8,9,10,11 中,数字 11 出现了 44 次。
输入输出格式
输入格式:
22个整数n,xn,x,之间用一个空格隔开。
输出格式:
11个整数,表示xx出现的次数。
输入输出样例
输入样例#1: 复制
11 1
输出样例#1: 复制
4
说明
对于 100\%100%的数据,1≤ n ≤ 1,000,000,0 ≤ x ≤ 91≤n≤1,000,000,0≤x≤9。
参考:https://www.luogu.org/problemnew/solution/P1980
思路:循环判断<=n的每个数中有几个x,对每个数判断其末位是不是x。反复求模和取余。(其实挺简单的,我也不知道自己为啥当时没想出来qaq。
代码:
#include <cstdio>
int main() {
int n,x;
scanf("%d %d",&n,&x);
int ans=0;
int t,a;
for(int i=1;i<=n;i++) {
t=i;
while(t!=0) {
a=t%10;
t=t/10;
if(a==x) {
ans++;
}
}
}
printf("%d\n",ans);
return 0;
}