hdu 1789 贪心

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3621    Accepted Submission(s): 2086


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source
贪心  这道题貌似有很多解法~~
将数据按分数从大到小排序,每次取最大分数的将其安排在截至期限的最后一天,如果此天已安排,则一直向前一天安排,直到不能安排,则加入s,,代码如下:
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
struct node
{
    int deline;
    int score;
};
node a[1005];
bool cmp(node lh,node rh)
{
    return lh.score>rh.score;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int i;
        for(i=0;i<n;i++)
            scanf("%d",&a[i].deline);
        for(i=0;i<n;i++)
            scanf("%d",&a[i].score);
        sort(a,a+n,cmp);
        bool b[1005];
        memset(b,false,sizeof(b));
        int s=0;
        for(i=0;i<n;i++)
        {
            int j=a[i].deline+1;
            while(--j)
            {
                if(b[j]==0)
                {
                    b[j]=1;
                    break;
                }
                else
                {
                    continue;
                }
            }
            if(j==0)
                s=s+a[i].score;
        }
        printf("%d\n",s);
    }
    return 0;
}

还担心了下效率,没想到过了~~~
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值