pku 3070 矩阵快速幂

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6946 Accepted: 4908

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

#include <iostream>
#include <cstring>
#include <cstdio>
#define MAX 2
using namespace std;
struct matrix
{
    int num[MAX][MAX];
    matrix()
    {
        memset(num,0,sizeof(num));
    }
};
matrix res;
matrix A;
matrix operator*(matrix &a,matrix &b)
{
    matrix t;
    int i,j,k;
    for(i=0;i<MAX;i++)
        for(j=0;j<MAX;j++)
            for(k=0;k<MAX;k++)
                t.num[i][j]=t.num[i][j]%10000+(a.num[i][k]*b.num[k][j])%10000;
    return t;
}
void quickpower(int n)
{
    while(n)
    {
        if(n&1)
            res=res*A;
        n>>=1;
        A=A*A;
    }
}
void init()
{
    res.num[0][0]=1;
    res.num[0][1]=0;
    res.num[1][0]=0;
    res.num[1][1]=1;
    A.num[0][0]=1;
    A.num[0][1]=1;
    A.num[1][0]=1;
    A.num[1][1]=0;
}
int main()
{
    int n;
    while(scanf("%d",&n),n!=-1)
    {
        init();
        quickpower(n);
        printf("%d\n",res.num[0][1]%10000);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值