Big Mod UVALive - 5346

Calculate R := B P mod M for large values of B, P, and M using an efficient algorithm. (That’s right, this problem has a time dependency !!!.) Input The input will contain several test cases, each of them as described below. Consecutive test cases are separated by a single blank line. Three integer values (in the order B, P, M) will be read one number per line. B and P are integers in the range 0 to 2147483647 inclusive. M is an integer in the range 1 to 46340 inclusive. Output For each test, the result of the computation. A single integer on a line by itself. Sample Input 3 18132 17 17 1765 3 2374859 3029382 36123 Sample Output 13 2 13195

 

#include <stdio.h>

typedef unsigned long long ULL;

ULL Mod(ULL a, ULL n, ULL m)
{
    ULL res = 1;
    while(n) {
        if((n & 1)==0)//(n&1)必须加括号
            ;
        else
        {
  //          printf("%d\n", n&1);
            res *= a;
            res %= m;
        }
        a *= a;
        a %= m;
        n >>= 1;
    }

    return res;
}

int main(void)
{
    ULL b, p, m;

    while(~scanf("%lld%lld%lld", &b, &p, &m)) {
        printf("%lld\n", Mod(b, p, m));
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值