HDU6024+简单dp

Building Shops

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 990    Accepted Submission(s): 382


Problem Description
HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.

The total cost consists of two parts. Building a candy shop at classroom i would have some cost ci . For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P 's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
 

Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1n3000) , denoting the number of the classrooms.
In the following n lines, each line contains two integers xi,ci(109xi,ci109) , denoting the coordinate of the i -th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
 

Output
For each test case, print a single line containing an integer, denoting the minimal cost.
 

Sample Input
  
  
3 1 2 2 3 3 4 4 1 7 3 1 5 10 6 1
 

Sample Output
  
  
5 11
 

Source
 

Recommend
jiangzijing2015   |   We have carefully selected several similar problems for you:   6032  6031  6030  6029  6028 


题意
有n个教学楼,现在在某个教学楼建小买铺,每个教学楼面临着建或不建小买铺的选择,求最小花费,此时大家应该想到dp(背包)
建小买铺 花费 pi
不建小买铺  花费为与左侧建立小买铺的教学楼之间的距离
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#define INF 1e18;
using namespace std;
struct tangguo
{
    int weizhi;
    int jiazhi;
}s[30005];
bool cmp(tangguo a,tangguo b)
{
    return a.weizhi<b.weizhi;
}
long long juli[3005][3005];//标记教学楼之间的距离
long long dp[3005][2];//dp[i][0]不建小买铺的花费,dp[i][1]建小买铺的花费
int main()
{
    int n;
    long long minn;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&s[i].weizhi,&s[i].jiazhi);
        }
        sort(s,s+n,cmp);
        for(int i=0;i<n;i++)
        {
            juli[i][i]=0;
            for(int j=i+1;j<n;j++)
            {
                juli[i][j]=juli[i][j-1]+s[j].weizhi-s[i].weizhi;//求出各个教学楼之间的距离
            }
        }
        for(int i=0;i<n;i++)
            dp[i][0]=dp[i][1]=INF;
        minn=INF;
        dp[0][1]=s[0].jiazhi;
        for(int i=1;i<n;i++)
        {
            dp[i][1]=min(dp[i-1][0],dp[i-1][1])+s[i].jiazhi;//求出第i个教学楼建小买铺的最小花费
            for(int j=i-1;j>=0;j--)
            {
                dp[i][0]=min(dp[j][1]+juli[j][i],dp[i][0]);//求出第i个教学楼不建的最小花费
            }
        }
        minn=min(dp[n-1][0],dp[n-1][1]);
        printf("%lld\n",minn);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值