2017女生赛 1002 Building Shops【dp】

Building Shops

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 26    Accepted Submission(s): 16


Problem Description
HDU’s  n  classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these  n  classrooms.

The total cost consists of two parts. Building a candy shop at classroom  i  would have some cost  ci . For every classroom  P  without any candy shop, then the distance between  P  and the rightmost classroom with a candy shop on  P 's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
 

Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer  n(1n3000) , denoting the number of the classrooms.
In the following  n  lines, each line contains two integers  xi,ci(109xi,ci109) , denoting the coordinate of the  i -th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
 

Output
For each test case, print a single line containing an integer, denoting the minimal cost.
 

Sample Input
  
  
3 1 2 2 3 3 4 4 1 7 3 1 5 10 6 1
 

Sample Output
  
  
5 11
 
      dp[i]表示建到i(且i建商店)的代价;

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b)  memset(a,b,sizeof(a))
const int M=1e4+10;
const int inf=0x3f3f3f3f;
int i,j,k,n,m;
ll dp[M];
struct node
{
    ll x,c;
}p[M];

bool cmp(node a,node b)
{
    return a.x<b.x;
}
ll len[M];

int main()
{
    int T;
    while(~scanf("%d",&n)){
       for(int i=1;i<=n;i++)
        scanf("%lld%lld",&p[i].x,&p[i].c);
        sort(p+1,p+n+1,cmp);
        len[0]=0;
        for(int i=1;i<=n;i++)
            len[i]=len[i-1]+p[i].x-p[1].x;
        ms(dp,inf);
        dp[1]=p[1].c;
        for(int i=2;i<=n;i++){
            for(int j=1;j<i;j++){
                if(j==i-1)dp[i]=min(dp[i],dp[j]+p[i].c);
                else dp[i]=min(dp[i],dp[j]+p[i].c+len[i-1]-len[j]-(i-1-j)*(p[j].x-p[1].x));
            }
        }
        ll ans=inf;
        for(int i=1;i<=n;i++){
             if(i==n)ans=min(ans,dp[n]);
            else ans=min(ans,dp[i]+len[n]-len[i]-(n-i)*(p[i].x-p[1].x));
        }
        printf("%lld\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值