poj Dropping tests 【二分】【分数规划】

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be 这里写图片描述
Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.
Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is 这里写图片描述. However, if you drop the third test, your cumulative average becomes 这里写图片描述.

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

题意:

给你若干分数,让你选择一定数量的分数让其分子和/分母和最大。
首先要认识到贪心是错的,随便举几个例子就能把看出来,所以这里就要用到二分的思想。

思路:

首先二分一个答案,然后验证取一定的分数能否满足这个答案。如果能满足,尝试更大的答案,不能满足就尝试更小的答案。
具体二分时,可以设置一个比例mid,(题目答案就是mid * 100),假设分子为ai,分母为bi,则只需要求能否找到一个sum = Σ ai - mid * bi 大于0即可

ac代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <functional>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
//#include <bits/stdc++.h>
using namespace std;
typedef long long ll;

int n, m, a[10005], b[10005];
const double eps = 1e-9;
double d[10005], ans, l, r, mid;
int main()
{
    while (scanf("%d %d", &n, &m))
    {
        if (n == 0 && m == 0)
            break;
        for (int i = 0; i < n; ++i)
            scanf("%d", &a[i]);
        for (int i = 0; i < n; ++i)
            scanf("%d", &b[i]);
        l = 0.0, r = 1.0;
        while (r - l > eps)
        {
            mid = (l + r) / 2.0;
            for (int i = 0; i < n; ++i)
                d[i] = (double)a[i] - mid * (double)b[i];
            sort(d, d + n);

            ans = 0;
            for (int i = n - 1; i >= m; i--)
                ans += d[i];

            if (ans >= 0)
                l = mid;
            else
                r = mid;
        }
        printf("%.0lf\n", (double)mid * 100.0);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值