HDU5573 Binary Tree

Binary Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 289    Accepted Submission(s): 170
Special Judge


Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1 . Say froot=1 .

And for each node u , labels as fu , the left child is fu×2 and right child is fu×2+1 . The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x , the number at the node is fx (remember froot=1 ), he can choose to increase his number of soul gem by fx , or decrease it by fx .

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N , then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given N , K , help the King find a way to collect exactly N soul gems by visiting exactly K nodes.
 

Input
First line contains an integer T , which indicates the number of test cases.

Every test case contains two integers N and K , which indicates soul gems the frog king want to collect and number of nodes he can visit.

1T100 .

1N109 .

N2K260 .
 

Output
For every test case, you should output " Case #x:" first, where x indicates the case number and counts from 1 .

Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a .

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

 

Sample Input
  
  
2 5 3 10 4
 

Sample Output
  
  
Case #1: 1 + 3 - 7 + Case #2: 1 + 3 + 6 - 12 +
 

Source
 题意:从一个1、2、3、4、5这样排下来的满二叉树里选择一条k层的路,这条路上的数可以加或者减,使得结果为N。
思路:看一下最左边的路1、2、4、8、16,根据二进制可以知道这些数可以组成2^k - 1以内的任意值,但是这条题要求经过的点必须'+'或者'-'而不是选或者不选,那么想不选某个数,相对于全选并且加起来,也就是前k-1项的和2^k - 1来说就是减去这个数的两倍(假设为d),那么d一定是偶数并且2^k - d = N。为了使得d是偶数我们可以在最后一个结点上选择左边或者右边,当d是偶数时选右边,当d是奇数时选左边。根据d可以用且运算知道哪些数是要减去的。
#include <stdio.h>
#define ll long long int
int main()
{
    int T, K = 1;
    ll n, k, d, u, i, end;
    scanf("%d", &T);
    while(T--){
        scanf("%I64d", &n);
        scanf("%I64d", &k);
        printf("Case #%d:\n", K++);
        d = ((ll)1 << k) - n;
        for(i = 1;i < k;i++){
            u = (ll)1 << i - 1;
            printf("%I64d ", u);
            if(((ll)1 << i) & d) printf("-\n");
            else printf("+\n");
        }
        end = (ll)1 << k - 1;
        if(d%2==0) printf("%I64d +\n", end + 1);
        else printf("%I64d +\n", end);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值