HDU - 5573

Binary Tree

The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.

And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given N, K, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.
Input
First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

⋅ 1≤T≤100.

⋅ 1≤N≤109.

⋅ N≤2K≤260.
Output
For every test case, you should output " Case #x:" first, where x indicates the case number and counts from 1.

Then K lines follows, each line is formated as ‘a b’, where a is node label of the node the frog visited, and b is either ‘+’ or ‘-’ which means he increases / decreases his number by a.

It’s guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

Sample Input
2
5 3
10 4
Sample Output
Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 +
题意:
给定一颗层数为K的完全二叉树,节点编号从上到下,从左到右,要求从根节点出发向下走,每经过一个节点可以选择加上或减去该节点编号的值,最终使结果等于n,输出经过节点的值和该节点加或减的结果。
题解:
由于给定了n的范围,所以使用最左侧的所有节点可以构造出1到n中的所有数,判断n的奇偶,如果为奇数,将最左侧节点全部相加,如果为偶数,将最后一层的节点换位相邻的右节点,这样做是为了使相加的数与n奇偶性相同,二者相减的值为偶数,然后将二者的差值除二记为d,由于所有最左侧节点相加结果比n多了2*d,所有在加的过程中少加一个d,再将d,减去,所得结果刚好为n,为了达到这一效果,由于最左侧节点编号二进制表达下都为 10000… 的形式,相加的最终结果为 111111… 的形式,所以将d二进制表达,该为为1,则减去,该为为0,则加上,就可以达到这一效果。

#include<stdio.h>
#include<algorithm>
using namespace std;
typedef long long ll;
int main() {
	int T;
	scanf("%d",&T);
	for(int cas=1; cas<=T; ++cas) {
		printf("Case #%d:\n",cas);
		ll n,k;
		scanf("%lld %lld",&n,&k);
		ll sum=1;
		ll ans=0;
		for(int i=1; i<k; ++i) {
			ans+=sum;
			sum<<=1;
		}
		if(n%2) {
			ans+=sum;
		} else {
			ans+=sum+1;
		}
		ll d=(ans-n)/2;
		sum=1;
		for(int i=1; i<k; ++i) {
			if(d&1) {
				printf("%d %c\n",sum,'-');
			} else {
				printf("%d %c\n",sum,'+');
			}
			sum<<=1;
			d>>=1;
		}
		if(n%2) {
			if(d&1) {
				printf("%d %c\n",sum,'-');
			} else {
				printf("%d %c\n",sum,'+');
			}
		} else {
			if(d&1) {
				printf("%d %c\n",sum+1,'-');
			} else {
				printf("%d %c\n",sum+1,'+');
			}
		}
	}
	return 0;
}

题解似乎写的挺乱的,我自己懂了,看完不懂的话再去看看大佬博客吧。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值