HDU1622 Trees on the level

Trees on the level

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 591    Accepted Submission(s): 200


Problem Description
Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree


is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

 

Input
The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

 

Output
For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed
 

Sample Input
  
  
(11,LL) (7,LLL) (8,R) (5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) () (3,L) (4,R) ()
 

Sample Output
  
  
5 4 8 11 13 4 7 2 1 not complete
 

Source
题意:给出给出二叉树上的点和它的位置,但有可能不能构成二叉树,例如没根节点或者同一位置有多个点存在。
思路:先建树再bfs遍历。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <queue>
using namespace std;
struct node{
    int v;
    node *l, *r;
};
char s[1005];
int pr[1005], tp;
queue<node*> q;
node* newNode(int v){
    node *t = (node*)malloc(sizeof(node));
    t->l = t->r = NULL;
    t->v = v;
    return t;
}
int judge;
char Map[300];
void Insert(node *root, int v, int level){
    for(int i = 0;i < level;i++){
        if(Map[i] == 'L'){
            if(root->l == NULL) root->l = newNode(-1);
            root = root->l;
        }else{
            if(root->r == NULL) root->r = newNode(-1);
            root = root->r;
        }
    }
    if(root->v != -1) judge = 0;
    root->v = v;
}
void bfs(node *s){
    tp = 0;
    if(s->v == -1) judge = 0;
    q.push(s);
    while(!q.empty()){
        node *now = q.front();
        q.pop();
        pr[tp++] = now->v;
        if(now->v == -1) judge = 0;
        if(now->l != NULL) q.push(now->l);
        if(now->r != NULL) q.push(now->r);
    }
}
int main(){
    int len, level, j, i, sum;
    while(scanf("%s", s) != EOF){
        judge = 1;
        node *root = newNode(-1);
        while(1){
            len = strlen(s);
            for(i = 0;i < len;i++)
            {
                if(s[i] != '(') continue;
                level = 0, j = i+1, sum = 0;
                while(s[j] != ')')
                {
                    if(s[j] >= '0'&&s[j] <= '9') sum = sum*10 + (s[j]-'0');
                    else if(s[j] != ',') Map[level++] = s[j];
                    j++;
                }
                if(sum != 0){
                    //Map[level] = '\0';
                    i = j - 1;
                    //printf("%d %s %d\n", sum, Map, level);
                    Insert(root, sum, level);
                }
            }
            if(s[len-2]=='('&&s[len-1]==')') break;
            scanf("%s", s);
        }
        bfs(root);
        if(!judge) printf("not complete\n");
        else{
            for(int i = 0;i < tp;i++)
                printf("%d%c", pr[i], i==tp-1?'\n':' ');
        }
    }
}

根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值