Trees on the level【 HDU - 1622 】

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree


is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

题意:

多组数据,每组数据中包含多个小数据,x代表节点值,y代表以根节点开始,向左向右走的路径,

每组以()结束。按照层次遍历输出。

如果不能构成一颗树的话,输出“not complete”。

代码:

#include<cstdio>
#include<cstring>
#include<map>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;


int num[500];
struct node
{
	int x,y;
	string s;
}e[1100];

bool cmp(node a,node b)
{
	if(a.y==b.y) return a.s<b.s;
	else return a.y<b.y;
}

int main()
{
	int n=0,flag=0;
	string str;
	map<string,int>v;
	while(cin>>str)
	{
		int i;
		if(str=="()")
		{
			sort(e,e+n,cmp);
			if(flag||e[0].y!=0)
			  printf("not complete\n");
			else
			{
				for(i=0;i<n;i++)
				{
					if(e[i].y>0)
					{
						string s;
						int l=e[i].s.size();
						for(int j=0;j<l-1;j++)
						  s+=e[i].s[j];
						if(v[s]!=1)
						 {
						 	flag=1;
						 	break;
						 }	 
					}
					num[i]=e[i].x;
				}
				
				if(flag)
				printf("not complete\n");
				else
				{
					for(i=0;i<n;i++)
					{
						if(i<n-1)
			              printf("%d ",num[i]);
						 else
						  printf("%d\n",num[i]);			
					}
				}
			}
			n=flag=0;
			v.clear();
			continue;
		}
		
		int x=0,l=str.size();
		
		for(i=1;i<l;i++)
		{
			if(str[i]==',')
			  break;
			x=x*10+str[i]-'0';
		}
		
		e[n].x=x;
		x=0;
		e[n].s.clear();
		for(i=i+1;i<l;i++)
		{
			if(str[i]==')')
			 break;
			 x++;
			e[n].s+=str[i];
		}
		v[e[n].s]++;
		if(v[e[n].s]>=2)
		 flag=1;
		 e[n].y=x;
		 n++;
	}
	return 0;
	 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值