HDU2196 Computer(树形DP)

21 篇文章 0 订阅
6 篇文章 0 订阅

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5106    Accepted Submission(s): 2577


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
 

Author
scnu
 
题意:已经有一台电脑,而后陆续再购买N-1台电脑,每台都与先前已经购买了得电脑里的某一台相连,线长li(假设的变量名),求出每个点能到达的最长距离。
思路:这里说得很简洁明了 http://blog.csdn.net/shuangde800/article/details/9732825,但是其实不必要建无限图的。

自己的代码:
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxn 10005
int dp[maxn][2], head[maxn];
int tot, N;
bool vis[maxn];
struct Edge{
    int to, next, cost;
}edge[maxn];
void add(int u, int v, int cost){
    edge[tot].to = v;
    edge[tot].cost = cost;
    edge[tot].next = head[u];
    head[u] = tot++;
}
void dfs1(int fa){
    vis[fa] = 1;
    int son, i;
    for(i = head[fa];i != -1;i = edge[i].next){
        son = edge[i].to;
        if(vis[son]) continue;
        dfs1(son);
        dp[fa][0] = max(dp[fa][0], dp[son][0] + edge[i].cost);
    }
}
void dfs2(int fa){
    int i, tmp, max1, max2, v1, v2, son;
    max1 = max2 = 0;
    vis[fa] = 1;
    for(i = head[fa];i != -1;i = edge[i].next){
        son = edge[i].to;
        if(vis[son]) continue;
        tmp = dp[son][0] + edge[i].cost;
        if(tmp > max1){
            max2 = max1, v2 = v1;
            max1 = tmp, v1 = son;
        }else if(tmp == max1||tmp > max2){
            max2 = tmp;
            v2 = son;
        }
    }

    tmp = dp[fa][1];
    if(tmp > max1){
        max2 = max1, v2 = v1;
        max1 = tmp, v1 = fa;
    }else if(tmp == max1||tmp > max2){
        max2 = tmp;
        v2 = fa;
    }

    for(i = head[fa];i != -1;i = edge[i].next){
        son = edge[i].to;
        if(vis[son]) continue;
        if(son != v1) dp[son][1] = max1 + edge[i].cost;
        else dp[son][1] = max2 + edge[i].cost;
        dfs2(son);
    }
}
int main()
{
    int i, u, cost;
    while(~scanf("%d", &N)){
        tot = 1;
        memset(head, -1, sizeof head);
        memset(dp, 0, sizeof dp);
        for(i = 2;i <= N;i++){
            scanf("%d %d", &u, &cost);
            add(u, i, cost);
        }

        memset(vis, 0, sizeof vis);
        dfs1(1);

        memset(vis, 0, sizeof vis);
        dfs2(1);
        for(i = 1;i <= N;i++) printf("%d\n", max(dp[i][0], dp[i][1]));
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值