hdu4614 Vases and Flowers(线段树+二分)

Vases and Flowers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2801    Accepted Submission(s): 1096


Problem Description
  Alice is so popular that she can receive many flowers everyday. She has N vases numbered from 0 to N-1. When she receive some flowers, she will try to put them in the vases, one flower in one vase. She randomly choose the vase A and try to put a flower in the vase. If the there is no flower in the vase, she will put a flower in it, otherwise she skip this vase. And then she will try put in the vase A+1, A+2, ..., N-1, until there is no flower left or she has tried the vase N-1. The left flowers will be discarded. Of course, sometimes she will clean the vases. Because there are too many vases, she randomly choose to clean the vases numbered from A to B(A <= B). The flowers in the cleaned vases will be discarded.
 

Input
  The first line contains an integer T, indicating the number of test cases.
  For each test case, the first line contains two integers N(1 < N < 50001) and M(1 < M < 50001). N is the number of vases, and M is the operations of Alice. Each of the next M lines contains three integers. The first integer of one line is K(1 or 2). If K is 1, then two integers A and F follow. It means Alice receive F flowers and try to put a flower in the vase A first. If K is 2, then two integers A and B follow. It means the owner would like to clean the vases numbered from A to B(A <= B).
 

Output
  For each operation of which K is 1, output the position of the vase in which Alice put the first flower and last one, separated by a blank. If she can not put any one, then output 'Can not put any one.'. For each operation of which K is 2, output the number of discarded flowers.
   Output one blank line after each test case.
 

Sample Input
  
  
2 10 5 1 3 5 2 4 5 1 1 8 2 3 6 1 8 8 10 6 1 2 5 2 3 4 1 0 8 2 2 5 1 4 4 1 2 3
 

Sample Output
  
  
[pre]3 7 2 1 9 4 Can not put any one. 2 6 2 0 9 4 4 5 2 3 [/pre]
 

Author
SYSU
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:   5679  5678  5677  5676  5675 
 题意:有两种操作:K=1:从A开始插F朵花;K=2:把A到B之间花去清空。对于K=1的操作,输出插第一朵花的位置和插最后一朵花的位置,K=2输出清空的数量。
思路:线段树的区间更新,不过要用二分来求得插花的位置。
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 50010
#define lson rt<<1
#define rson rt<<1|1
using namespace std;
struct node{
    int left, right;
    int flag, sum;
    int dis(){return right-left+1;}
}t[maxn<<2];
int s, e;
void pushUp(int rt){
    t[rt].sum = t[lson].sum + t[rson].sum;
}
void pushDown(int rt){
    if(t[rt].flag != -1){
        int mid = (t[rt].right+t[rt].left)>>1;
        t[lson].flag = t[rson].flag = t[rt].flag;
        if(t[rt].flag == 1){
            t[lson].sum = t[lson].dis();
            t[rson].sum = t[rson].dis();
        }
        else t[lson].sum = t[rson].sum = 0;
        t[rt].flag = -1;
    }
}
void build(int rt, int l, int r){
    t[rt].left = l;
    t[rt].right = r;
    t[rt].flag = -1;
    if(l == r){
        t[rt].sum = 0;
        return;
    }
    int mid = (l+r)>>1;
    build(lson, l, mid);
    build(rson, mid+1, r);
    pushUp(rt);
}
void updata(int rt, int l, int r, int op){
    if(l<=t[rt].left&&t[rt].right<=r){
        t[rt].flag = op;
        if(op == 1) t[rt].sum = t[rt].dis();
        else t[rt].sum = 0;
        return;
    }
    pushDown(rt);
    int mid = (t[rt].left+t[rt].right)>>1;
    if(l<=mid) updata(lson, l, r, op);
    if(mid<r) updata(rson, l, r, op);
    pushUp(rt);
}
int query(int rt, int l, int r){
    if(l<=t[rt].left&&t[rt].right<=r){
        return t[rt].sum;
    }
    pushDown(rt);
    int sum = 0;
    int mid = (t[rt].left+t[rt].right)>>1;
    if(l<=mid) sum += query(lson, l, r);
    if(mid<r) sum += query(rson, l, r);
    return sum;
}
int Binary(int pos, int n, int F){
    int l, r, mid, ans;
    l = pos, r = n;
    ans = query(1, l, n);
    if(ans == n-l+1) return -1;
    while(l<=r){
        mid = (l+r)>>1;
        ans = query(1, pos, mid);
        if(ans<mid-pos+1) r = mid-1;
        else l = mid+1;
    }
    if(ans == 1) s = l+1;

    s = l;//printf("start:%d\n", s);
    r = n;
    ans = query(1, s, n);
    if(ans+F>n-s+1) F = n-s+1-ans;
    while(l<=r){
        mid = (l+r)>>1;
        ans = query(1, s, mid);
        if(ans+F == mid-s+1){
            e = mid;
            r = mid-1;
        }else if(ans+F < mid-s+1) r = mid-1;
        else l = mid+1;
    }
    return 1;
}
int main(){
    int T, n, m, k, a, b;
    scanf("%d", &T);
    while(T--){
        scanf("%d %d",&n, &m);
        build(1, 0, n-1);
        while(m--){
            scanf("%d %d %d", &k, &a, &b);
            if(k == 1){
                if(Binary(a, n-1, b) != -1){
                    updata(1, s, e, 1);
                    printf("%d %d\n", s, e);
                }else printf("Can not put any one.\n");
            }else{
                printf("%d\n", query(1, a, b));
                updata(1, a, b, 0);
            }
        }
        printf("\n");
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值