2005

题目编号:2005

Problem Description
Mr. West bought a new car! So he is travelling around the city.<br><br>One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.<br><br>Can Mr. West go across the corner?<br><img src=../../../data/images/2438-1.jpg><br>
 

Input
Every line has four real numbers, x, y, l and w.<br>Proceed to the end of file.<br>
 

Output
If he can go across the corner, print "yes". Print "no" otherwise.<br>
 

Sample Input
  
  
10 6 13.5 4<br>10 6 14.5 4<br>
 

Sample Output
  
  
yes<br>no<br>
 

Source
2008 Asia Harbin Regional Contest Online
 
AC代码:#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#define pi 3.1415
using namespace std;


const double eps = 1e-4;


double l,x,y,w;


double calu(double a){
    return l*cos(a)+(w-x*cos(a))/sin(a);
}


double ternary_search(double l,double r){
    double ll,rr;
    while(r-l>eps){
        ll=(2*l+r)/3;
        rr=(2*r+l)/3;
        if(calu(ll)>calu(rr))
            r=rr;
        else
            l=ll;
    }
    return r;
}


int main()
{
    while(cin>>x>>y>>l>>w){
        double l=0,r=pi/2;
        double tmp=ternary_search(l,r);
        if(calu(tmp)<=y)
            puts("yes");
        else
            puts("no");
    }
    return 0;
}

三分搜索

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值