HDU_P2438 Turn the corner(三分)

6 篇文章 0 订阅
2 篇文章 0 订阅

HDU传送门

Mr. West bought a new car! So he is travelling around the city.
One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.
Can Mr. West go across the corner?

Input
Every line has four real numbers, x, y, l and w.
Proceed to the end of file.

Output
If he can go across the corner, print “yes”. Print “no” otherwise.

Sample Input
10 6 13.5 4
10 6 14.5 4

Sample Output
yes
no

Source
2008 Asia Harbin Regional Contest Online

Recommend
gaojie | We have carefully selected several similar problems for you: 2444 2441 2442 2443 2440

Sol:
暴力复制题解
这里写图片描述

#include<cstdio>
#include<cmath>
#define Pi acos(-1.0)
#define eps 1e-8
double x,y,l,w;
inline double f(double a){return l*cos(a)+(w-x*cos(a))/sin(a);}
int main(){
    double L,R,M,l2,r2;
    while(~scanf("%lf%lf%lf%lf",&x,&y,&l,&w)){
        L=0,R=Pi/2.0;
        while(R-L>eps){
            M=(R-L)/3.0;l2=L+M,r2=R-M;
            if(f(l2)>f(r2)) R=r2;else L=l2;
        }
        if(f(L)>y) puts("no");else puts("yes");
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值