Turn the corner HDU - 2438 三分 枚举角度 几何

Description

Mr. West bought a new car! So he is travelling around the city.

One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.

Can Mr. West go across the corner?
这里写图片描述

Input

Every line has four real numbers, x, y, l and w.
Proceed to the end of file.

Output

If he can go across the corner, print “yes”. Print “no” otherwise.

Sample Input

10 6 13.5 4
10 6 14.5 4

Sample Output

yes
no

Hint

题意

题解:

利用角度关系构造函数 求出车在转弯时所占据的长度 这个长度最大值如果大于y说明过不去 可以找到这个长度的函数表达式
f (t) = l*cos(t)+(w-x*cos(t))/sin(t);

AC代码

#include <cstdio>
#include <iostream>
#include <queue>
#include <map>
#include <vector>
#include <cmath>
#include <set>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const double eps = 1e-8;
double x,y,l,w;
double check(double t){
    double ans = l*cos(t)+(w-x*cos(t))/sin(t);
    return ans;
}
int main(){

    while (scanf("%lf%lf%lf%lf",&x,&y,&l,&w)!=EOF){
        double l = 0,r = acos(-1.0)/2;
        while (r-l>eps){
            double ll = (2*l+r)/3;
            double rr = (2*r+l)/3;
            double ans1 = check(ll);
            double ans2 = check(rr);
            if (ans1<ans2) l = ll;
            else r = rr;
        }
        if (check(l)>y) printf("no\n");
        else printf("yes\n");
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值