POJ 3566


Building for UN
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 1367 Accepted: 599 Special Judge

Description

The United Nations has decided to build a new headquarters in Saint Petersburg, Russia. It will have a form of a rectangular parallelepiped and will consist of several rectangular floors, one on top of another. Each floor is a rectangular grid of the same dimensions, each cell of this grid is an office.

Two offices are considered adjacent if they are located on the same floor and share a common wall, or if one’s floor is the other’s ceiling.

The St. Petersburg building will host n national missions. Each country gets several offices that form a connected set.

Moreover, modern political situation shows that countries might want to form secret coalitions. For that to be possible, each pair of countries must have at least one pair of adjacent offices, so that they can raise the wall or the ceiling they share to perform secret pair-wise negotiations just in case they need to.

You are hired to design an appropriate building for the UN.

Input

The input file consists of a single integer number n (1 ≤ n ≤ 50) — the number of countries that are hosted in the building.

Output

On the first line of the output file write three integer numbers h, w, and l — height, width and length of the building respectively.

h descriptions of floors should follow. Each floor description consists of l lines with w characters on each line. Separate descriptions of adjacent floors with an empty line.

Use capital and small Latin letters to denote offices of different countries. There should be at most 1 000 000 offices in the building. Each office should be occupied by a country. There should be exactly n different countries in the building. In this problem the required building design always exists.

Sample Input

4

Sample Output

2 2 2
AB
CC

zz
zz

Source



题意:安排楼层(矩形格子)使各个国家啊都相邻,输出一种情况。

思路:每一层w=2,第一行是不同的n个国家,第二行都是某一个国家,这样保证了每个国家都与别的国家相邻。假设题目的4,结果就为
4 4 2
ABCD
AAAA

ABCD
BBBB

ABCD
CCCC

ABCD
DDDD

AC代码:
import java.util.*;
public class Main {

	public static void main(String[] args) {
		Scanner scan=new Scanner (System.in);
		char a[]=new char[60];
		int i,j;
		for(i=0;i<26;i++) a[i]=(char) ('A'+i);
		for(j=0;j<26;j++,i++) a[i]=(char) ('a'+j);
		while(scan.hasNext()){
			int n=scan.nextInt();
			System.out.println(n+" "+n+" "+2);
			for(i=0;i<n;i++){
				for(j=0;j<n;j++){
					System.out.print(a[j]);
				}
				System.out.println();
				for(j=0;j<n;j++){
					System.out.print(a[i]);
				}
				System.out.println();
				if(i!=n-1) System.out.println();
			}
		}
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值