poj 3566 Building for UN(为联合国而建)

[题目链接] (http://poj.org/problem?id=3566)
题目描述:
Building for UN
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 1784 Accepted: 802 Special Judge
Description

The United Nations has decided to build a new headquarters in Saint Petersburg, Russia. It will have a form of a rectangular parallelepiped and will consist of several rectangular floors, one on top of another. Each floor is a rectangular grid of the same dimensions, each cell of this grid is an office.

Two offices are considered adjacent if they are located on the same floor and share a common wall, or if one’s floor is the other’s ceiling.

The St. Petersburg building will host n national missions. Each country gets several offices that form a connected set.

Moreover, modern political situation shows that countries might want to form secret coalitions. For that to be possible, each pair of countries must have at least one pair of adjacent offices, so that they can raise the wall or the ceiling they share to perform secret pair-wise negotiations just in case they need to.

You are hired to design an appropriate building for the UN.

Input

The input file consists of a single integer number n (1 ≤ n ≤ 50) — the number of countries that are hosted in the building.

Output

On the first line of the output file write three integer numbers h, w, and l — height, width and length of the building respectively.

h descriptions of floors should follow. Each floor description consists of l lines with w characters on each line. Separate descriptions of adjacent floors with an empty line.

Use capital and small Latin letters to denote offices of different countries. There should be at most 1 000 000 offices in the building. Each office should be occupied by a country. There should be exactly n different countries in the building. In this problem the required building design always exists.

Sample Input

4
Sample Output

2 2 2
AB
CC

zz
zz
Source

Northeastern Europe 2007
言简意赅:
此题主要考察对题目的抽象处理,把算法抽象出来也不过是要满足两个条件的输出:条件1:每个国家的总部办公室都要连接(在隔壁或者上下层)在一起;条件2:每两个国家之间要彼此连接在一起;
纵观,则可以把其抽象为如图所示的样子:
以n==4为例
以n==4为例
代码实现如下:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        printf("%d %d 2\n",n,n);
        if(n<=25)
        {
            for(int k=0; k<n; k++)
            {
                for(int i=0; i<n; i++)
                {
                    printf("%c",'A'+i);
                }
                printf("\n");
                for(int i=0; i<n; i++)
                {
                    printf("%c",'A'+k);
                }
                printf("\n");
                printf("\n");
            }
        }
        else
        {
            int i,k;
            for(k=0; k<n; k++)
            {
                for(i=0; i<26; i++)
                {
                    printf("%c",'A'+i);
                }
                for(int p=0; p<n-26; p++)
                {
                    printf("%c",'a'+p);
                }
                printf("\n");
                if(k<26)
                for(i=0;i<n;i++)
                {
                    printf("%c",'A'+k);
                }
                if(k>=26)
                for(int p=0;p<n;p++)
                {
                    printf("%c",'a'+k-26);
                }
                printf("\n");
                printf("\n");
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值