Corn FieldsCrawling in process... Crawling failed Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Description
Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.
Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.
Input
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output
Sample Input
2 3 1 1 1 0 1 0
Sample Output
9
Hint
1 2 3 4
There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
题意:不能放在相邻的1上,可以一个都不放,问有多少种方法。
思路:第一个状压DP,脑子不够用啊,看着看着就能看懂啦。dp[i][j]是第i行的第j种状态的所有种类。
AC代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>
using namespace std;
int line[15];
int state[1000];
int dp[15][1000];
int n,m,k;
bool ok(int x){
if(x&(x<<1)) return false;
return true;//一行没有相邻的1;
}
int main(){
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
int temp;
scanf("%d",&temp);
if(temp==0) line[i]=line[i]|(1<<j);
}
}
k=0;
memset(state,0,sizeof(state));
for(int i=0;i<(1<<m);i++){
if(ok(i)){
state[k++]=i;
}
}
for(int i=0;i<k;i++){
if(!(state[i]&line[0]))
dp[0][i]=1;
}
for(int i=1;i<n;i++){
for(int j=0;j<k;j++){
if(line[i-1]&state[j]) continue;
for(int l=0;l<k;l++){
if(line[i]&state[l]) continue;
if(state[l]&state[j]) continue;
dp[i][l]=(dp[i][l]+dp[i-1][j])%100000000;
}
}
}
int ans=0;
for(int i=0;i<k;i++){
ans=(ans+dp[n-1][i])%100000000;
}
printf("%d\n",ans);
return 0;
}