Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Output
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
通俗讲就是 n可以+1可以-1可以*2 让n=k 最少要几步
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int vis[1000001];
struct node
{
int wei;
int time;
};
int main()
{
int n,k;
while(scanf("%d%d",&n,&k)!=EOF)
{
if(n==k)
{
printf("0\n");
continue;
}
memset(vis,0,sizeof(vis));
struct node start;
start.wei =n;
start.time =0;
vis[n]=1;
queue<node>q;
q.push(start);
while(!q.empty() )
{
struct node tmp=q.front();
q.pop();
if(tmp.wei-1==k||tmp.wei +1==k||tmp.wei *2==k)
{
printf("%d\n",tmp.time+1 );
break;
}
tmp.time++;
struct node tmp2;
if(tmp.wei +1<k)
{
tmp2=tmp;
tmp2.wei ++;
if(vis[tmp2.wei]==0)
{
vis[tmp2.wei]=1;
q.push(tmp2) ;
}
}
if(tmp.wei-1>0&&tmp.wei-1!=k)
{
tmp2=tmp;
tmp2.wei--;
if(vis[tmp2.wei ]==0)
{
vis[tmp2.wei]=1;
q.push(tmp2) ;
}
}
if(tmp.wei<k)
{
tmp2=tmp;
tmp2.wei=2*tmp.wei
;
if(vis[tmp2.wei]==0)
{
vis[tmp2.wei]=1;
q.push(tmp2) ;
}
}
}
}
return 0;
}