hdu 3549Flow Problem

Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2
第一次做网络流,套了EK算法模板,EK算法的时间复杂度是O(n*m^2 ),n是点的个数,m是边的个数。
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<string>
#include<bitset>
#include<algorithm>
using namespace std;
#define lson th<<1
#define rson th<<1|1
typedef long long ll;
typedef long double ldb;
#define inf 99999999
#define pi acos(-1.0)
#define Key_value ch[ch[root][1]][0]

const int N=20;
int n,m,gra[N][N],path[N],flow[N],st,ed;
queue<int>q;

int bfs()
{
    int i,t;
    while(!q.empty())q.pop();
    memset(path,-1,sizeof(path));
    path[st]=0;flow[st]=inf;
    q.push(st);
    while(!q.empty()){
        t=q.front();
        q.pop();
        if(t==ed)break;
        for(i=1;i<=n;i++){
            if(i!=st && path[i]==-1 && gra[t][i]){
                flow[i]=flow[t]<gra[t][i]?flow[t]:gra[t][i];
                q.push(i);
                path[i]=t;
            }
        }
    }
    if(path[ed]==-1)return -1;
    return flow[n];
}


int Edmonds_Karp()
{
    int max_flow=0,step,now,pre;
    while((step=bfs())!=-1 ){
        max_flow+=step;
        now=ed;
        while(now!=st){
            pre=path[now];
            gra[pre][now]-=step;
            gra[now][pre]+=step;
            now=pre;
        }
    }
    return max_flow;
}



int main()
{
    int i,u,v,cost,T,c,d,e,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(gra,0,sizeof(gra));
        for(i=1;i<=m;i++){
            scanf("%d%d%d",&c,&d,&e);
            gra[c][d]+=e;
        }
        st=1;ed=n;
        printf("Case %d: %d\n",++cas,Edmonds_Karp());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值