D - Hie with the Pie

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input
3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0
Sample Output
8

      题意:给1个店+n个地方,下面给(n+1)的矩阵,代表每两点之间的距离,要求没个点都送货,最后会回店铺0,求最短送货距离。

      对地图mp【】【】,先Floyd求每两点最短距离,然后dp。

      这里是n个地方,可以用0/1表示某个地方去没去过,这样整体的n个点表示成一个二进制数,共1<<n个状态。dp【i】【j】表示当前状态为i,且当前点为j的距离。

      可得dp方程:dp【i】【now】=min(dp【i】【now】, dp【(i & (1<<(now-1)))】【pre】+mp【pre】【now】),now、pre代表当前点、上一个点。

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[(1<<12)][12];//代表去过点的状态为i,且当前在j时的距离
int mp[12][12];
int main()
{
    int N;
    while(cin>>N && N)
    {
        memset(dp, 0x3f, sizeof(dp));
        for(int i=0; i<=N; i++)
        {
            for(int j=0; j<=N; j++)
            {
                cin>>mp[i][j];
            }
        }
        for(int k=0; k<=N; k++)//Floyd求最短距离
        {
            for(int i=0; i<=N; i++)
            {
                for(int j=0; j<=N; j++)
                {
                    mp[i][j]=min(mp[i][j], mp[i][k]+mp[k][j]);
                }
            }
        }
        int M=1<<N;//N个点,(*****) *等于1代表去过
        for(int i=0; i<M; i++)//i代表状态
        {
            for(int j=1; j<=N; j++)//去第j个点
            {
                if(i==(1<<(j-1)))//如果这个点是第一个去的点
                    dp[i][j]=mp[0][j];
                else
                {
                    for(int k=1; k<=N; k++)//pre点
                    {
                        if((k!=j) && (i & (1<<(k-1)))) //如果pre点去过了 DP
                            dp[i][j]=min(dp[i][j], dp[i ^ (1<<(j-1))][k]+mp[k][j]);
                    }
                }
            }
        }
        int ans=dp[M-1][1]+mp[1][0];//最后要回0点
        for(int i=0; i<=N; i++)
        {
            ans=min(ans, dp[M-1][i]+mp[i][0]);
        }
        cout<<ans<<endl;
    }
    
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值