hdu5437 Alisha’s Party

Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value  v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let  p  people enter her castle. If there are less than  p  people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query  n  Please tell Alisha who the  nth  person to enter her castle is.
 

Input
The first line of the input gives the number of test cases,  T  , where  1T15 .

In each test case, the first line contains three numbers  k,m  and  q  separated by blanks.  k  is the number of her friends invited where  1k150,000 . The door would open m times before all Alisha’s friends arrive where  0mk . Alisha will have  q  queries where  1q100 .

The  ith  of the following  k  lines gives a string  Bi , which consists of no more than  200  English characters, and an integer  vi 1vi108 , separated by a blank.  Bi  is the name of the  ith  person coming to Alisha’s party and Bi brings a gift of value  vi .

Each of the following  m  lines contains two integers  t(1tk)  and  p(0pk)  separated by a blank. The door will open right after the  tth  person arrives, and Alisha will let  p  friends enter her castle.

The last line of each test case will contain  q  numbers  n1,...,nq  separated by a space, which means Alisha wants to know who are the  n1th,...,nqth  friends to enter her castle.

Note: there will be at most two test cases containing  n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
  
  
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
  
  
Sorey Lailah Rose

这题可以用set或者优先队列模拟一下,每次在指定的时间读入指定的人数,这些人按照价值从大到小排序,然后当门打开的时候记录它的信息,便于待会输出结果,这里有一点要注意,就是最后m个指令读完后还有人在外面,那么把要这些人都按照规则放入门内。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define ll long long
#define inf 999999999
#define maxn 150060
char s[maxn][205],str[maxn][205];
int v[maxn];
struct node{
    int idx,v;
}a,temp,temp1;

bool operator<(node a,node b){
    if(a.v==b.v)return a.idx<b.idx;
    else return a.v>b.v;
}
multiset<node>myset;
multiset<node>::iterator  it;

struct node1{
    int t,num;
}b[maxn];

bool cmp(node1 a,node1 b){
    return a.t<b.t;
}

int main()
{
    int n,m,i,j,T,t,num,tot,now,c,q,ans;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&q);
        for(i=1;i<=n;i++){
            scanf("%s%d",s[i],&v[i]);
        }
        for(i=1;i<=m;i++){
            scanf("%d%d",&b[i].t,&b[i].num);
        }
        sort(b+1,b+1+m,cmp);



        tot=0;now=0;
        myset.clear();
        for(i=1;i<=m;i++){
            while(now<b[i].t){
                now++;
                a.idx=now;a.v=v[now];
                myset.insert(a);
            }
            ans=0;
            while(ans<b[i].num){
                if(myset.empty())break;
                ans++;
                it=myset.begin();
                temp=*it;
                tot++;
                strcpy(str[tot],s[temp.idx]);
                myset.erase(it);
            }

        }
        while(now<n){
            now++;
            a.idx=now;a.v=v[now];
            myset.insert(a);
        }
        while(tot<n){
            it=myset.begin();
            temp=*it;
            tot++;
            strcpy(str[tot],s[temp.idx]);
            myset.erase(it);
        }


        for(i=1;i<=q;i++){
            scanf("%d",&c);
            if(i==q){
                printf("%s\n",str[c]);
            }
            else printf("%s ",str[c]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值