hdu4028 The time of a day (map+dp)

7 篇文章 0 订阅
Problem Description
There are no days and nights on byte island, so the residents here can hardly determine the length of a single day. Fortunately, they have invented a clock with several pointers. They have N pointers which can move round the clock. Every pointer ticks once per second, and the i-th pointer move to the starting position after i times of ticks. The wise of the byte island decide to define a day as the time interval between the initial time and the first time when all the pointers moves to the position exactly the same as the initial time.
The wise of the island decide to choose some of the N pointers to make the length of the day greater or equal to M. They want to know how many different ways there are to make it possible.
 

Input
There are a lot of test cases. The first line of input contains exactly one integer, indicating the number of test cases.
  For each test cases, there are only one line contains two integers N and M, indicating the number of pointers and the lower bound for seconds of a day M. (1 <= N <= 40, 1 <= M <= 2 63-1)
 

Output
For each test case, output a single integer denoting the number of ways.
 

Sample Input
  
  
3 5 5 10 1 10 128
 

Sample Output
  
  
Case #1: 22 Case #2: 1023 Case #3: 586
 
题意:给你n个数,这n个数的大小为1~n,让你从中挑出一些数,使得这些数的最小公倍数大于等于m,求挑选的方案数。
思路:因为数的最小公倍数很大,所以不好dp,但是我们打表可以发现不同最小公倍数的总数量不是很大,所以我们用map<ll,ll>dp[50]来表示前i个数中挑选出的数的最小公倍数的值为j的方案数。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef long double ldb;
#define inf 99999999
#define pi acos(-1.0)
ll gcd(ll a,ll b){
    return (b>0)?gcd(b,a%b):a;
}

ll cal(ll x,ll y)
{
    ll num;
    num=gcd(x,y);
    return x*y/num;

}
map<ll,ll>dp[50];
map<ll,ll>::iterator it;

void init()
{
    int i,j;
    for(i=1;i<=40;i++)dp[i].clear();
    dp[1][1]=1;
    for(i=2;i<=40;i++){
        for(it=dp[i-1].begin();it!=dp[i-1].end();it++){
            dp[i][it->first]+=it->second;
            dp[i][cal(it->first,i) ]+=it->second;
        }
        dp[i][i]+=1;
    }
}

int main()
{
    int i,j,T,cas=0;;
    ll n,m;
    init();
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld%lld",&n,&m);
        ll sum=0;
        for(it=dp[n].lower_bound(m);it!=dp[n].end();it++){
           if(it->first>=m)
           sum+=(it->second);
        }
        cas++;
        printf("Case #%d: %lld\n",cas,sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值