UESTC 1218 Pick The Sticks

Time Limit: 15000/10000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
 

The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became 

very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army.

 Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he's clever? By looking at 

the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only 

use one stick as the container.

Formally, we can treat the container stick as an  L  length segment. And the gold sticks as segments too. There were many gold sticks with different 

length  ai  and value  vi . Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. 

Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long 

as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So 

no one knows how many gold sticks Xiu Yang made it in the container.


Can you help solve the mystery by finding out what's the maximum value of the gold sticks Xiu Yang could have taken?

Input

The first line of the input gives the number of test cases,  T ( 1T100 ).  T  test cases follow. Each test case start 

with two integers,  N ( 1N1000 ) and  L ( 1L2000 ), represents the number of gold sticks and the length 

of the container stick.  N  lines follow. Each line consist of two integers,  ai ( 1ai2000 ) and  vi ( 1vi109 ), 

represents the length and the value of the  ith  gold stick.

Output

For each test case, output one line containing Case #x: y, where  x  is the test case number (starting from  1 ) and  y  is 

the maximum value of the gold sticks Xiu Yang could have taken.

Sample input and output

Sample Input Sample Output
4

3 7
4 1
2 1
8 1

3 7
4 2
2 1
8 4

3 5
4 1
2 2
8 9

1 1
10 3
Case #1: 2
Case #2: 6
Case #3: 11
Case #4: 3

Hint

In the third case, assume the container is lay on  x -axis from  0  to  5 . Xiu Yang could put the second gold stick center at  0  and put the third gold stick

 center at  5 , so none of them will drop and he can get total  2+9=11  value. In the fourth case, Xiu Yang could just put the only gold stick center 

on any position of  [0,1] , and he can get the value of  3


题意:给你一根长为m的长木板和一些小木棒,每一根小木棒有它的长度和价值,这些小木棒要放在长木板上并且每一根小木棒的重心要在长木板上

(即可以露出一半的长),问最大价值是多少。

思路:主要是dp方程要想到,用dp[i][j][k]表示处理到第i根木棒,长木板用了j的长度,有k根露在外面的最大价值,因为对于每根木棒,有三种情况,

一种是不放,一种是放在木板里面,还有一种是放在木板外面。这里注意要用滚动数组,不然会超内存。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x7fffffff
#define maxn 4005
ll l[maxn],v[maxn];
ll dp[2][maxn*2][3];


int main()
{
    int n,m,i,j,T,len,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        m*=2;
        for(i=1;i<=n;i++){
            scanf("%lld%lld",&l[i],&v[i]);
            l[i]*=2;
        }

        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++){
            //不放
            for(j=0;j<=m;j++){
                dp[1][j][0]=dp[0][j][0];
                dp[1][j][1]=dp[0][j][1];
                dp[1][j][2]=dp[0][j][2];
            }
            //放里面
            for(j=m;j>=l[i];j--){
                dp[1][j][0]=max(dp[1][j][0],dp[0][j-l[i] ][0]+v[i]);
                dp[1][j][1]=max(dp[1][j][1],dp[0][j-l[i] ][1]+v[i]);
                dp[1][j][2]=max(dp[1][j][2],dp[0][j-l[i] ][2]+v[i]);
            }
            //放外面
            for(j=m;j>=l[i]/2;j--){
                dp[1][j][1]=max(dp[1][j][1],dp[0][j-l[i]/2 ][0]+v[i]);
                dp[1][j][2]=max(dp[1][j][2],dp[0][j-l[i]/2 ][1]+v[i]);
            }

            for(j=0;j<=m;j++){
                dp[0][j][0]=dp[1][j][0];
                dp[0][j][1]=dp[1][j][1];
                dp[0][j][2]=dp[1][j][2];
            }

        }
        ll ans=dp[1][m][0];
        ans=max(ans,dp[1][m][1]);
        ans=max(ans,dp[1][m][2]);
        for(i=1;i<=n;i++){
            ans=max(ans,v[i]);
        }
        cas++;
        printf("Case #%d: %lld\n",cas,ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
互联网络程序设计是指在互联网上进行程序开发和设计的过程。UESTC则是我国的一所著名高校——电子科技大学。 互联网络程序设计 uestc包含了两个主要的方面:互联网络和程序设计。互联网络是指将多个计算机网络通过通信链路互相连接起来,实现信息共享和资源共享的网络系统。程序设计是指根据需求和目标,通过编写代码和设计算法,实现计算机程序的过程。 互联网络程序设计 uestc的学习内容主要包括以下几个方面: 1. 网络知识:学习互联网络的基本概念、原理和协议,如TCP/IP协议、HTTP协议等。掌握网络编程的基本技术,能够编写网络应用程序。 2. 数据通信:学习数据通信的基本原理和技术,包括数据传输的方式、数据压缩和加密等。了解网络安全和数据保护的基本知识。 3. 程序设计:学习编程语言和开发工具,如Java、C++和Python等。掌握常用的编程技巧和方法,能够设计和实现复杂的网络应用程序。 4. Web开发:学习Web开发的基本知识和技术,包括HTML、CSS、JavaScript等。能够设计和实现交互式的Web应用程序。 5. 数据库技术:学习数据库的基本原理和技术,如SQL语言和数据库管理系统。能够设计和管理数据库,实现数据的存储和检索。 通过学习互联网络程序设计 uestc,可以掌握互联网应用开发的基本技能,具备设计和实现网络应用程序的能力。这对于目前互联网行业的人才需求来说是非常重要的,也为学生提供了广阔的就业和创业机会。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值