UVA 1193 (区间覆盖(贪心))

题意是:在直角坐标系中,x方向是海岸线,x轴上方是岛屿,问至少有又多少个雷达才能把所有岛屿影响到,这题有个坑,输出-1时有几种情况:1.d<0 2.y<0 3.y>d,我们可以把每个岛屿的位置和d通过直角转换成x轴方向的点,然后题目就变成区间覆盖问题了

Description

Download as PDF

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d .

We use Cartesian coordinate system, defining the coasting is the x -axis. The sea side is above x -axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x - y coordinates.

\epsfbox{p2519.eps}

Input 

The input consists of several test cases. The first line of each case contains two integers n(1$ \le$n$ \le$1000) and d , where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros.

Output 

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. `-1' installation means no solution for that case.

Sample Input 

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output 

Case 1: 2
Case 2: 1
AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
#include<map>
#include<set>
#define INF 999999999
#define LL long long
#define mod 1000003
using namespace std;
struct node
{
	double zuo, you;
};
node po[1005];
int cmp(node a, node b)
{
	return a.zuo < b.zuo;
}
int main()
{
	int n, d;
	int cnt = 0;
	while (scanf("%d%d", &n, &d)&&n&&d)
	{
		int f = 0;
		double x, y;
		for (int i = 0; i < n; i++)
		{
			scanf("%lf%lf", &x, &y);
			if (y > d||y<0||d<0)
				f = 1;
			else
			{
				//转化为区间
				int xx = int(sqrt(d*d - y*y));
				po[i].zuo = x - xx, po[i].you = x + xx;
			}
		}
		printf("Case %d: ", ++cnt);
		if (f)
		{
			printf("-1\n");
			continue;
		}
		int ans = 1;
		sort(po, po + n, cmp);
		int xx = po[0].you;
		for (int i = 1; i < n; i++)
		{
			if (po[i].zuo > xx)
			{
				ans++;
				xx = po[i].you;
			}
			else if (po[i].zuo < xx&&po[i].you < xx)
			{
				xx = po[i].you;
			}
		}
		printf("%d\n", ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值