poj1469 COURSES(二分图)

题意:有n个学生,p个课程,给出每个课程会有哪些学生去上课,要求我们是否能满足每个课程对应一个不同的学生,这就是二分图匹配,通过非匹配边到匹配边的递归查找,找到最大匹配。这是最简单的二分图,详细看代码模板

COURSESTime Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%lld & %llu

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student 1 1 Student 1 2 ... Student 1 Count1
Count2 Student 2 1 Student 2 2 ... Student 2 Count2
...
CountP Student P 1 Student P 2 ... Student P CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO
AC代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#define maxn 304
using namespace std;
int n, p;
int W[105][maxn];//记录边的权值
int lef[maxn];//学生的课程匹配点值
bool T[maxn];//递归标记,已搜过的不用再搜
bool match(int i)//i是课程
{
	for (int j = 1; j <= n; j++)//j是学生
	{
		if (W[i][j] && !T[j])
		{
			T[j] = true;
			if (lef[j] == 0 || match(lef[j]))//满足条件:学生和课程没匹配或存在增广路(即非匹配边-匹配边··-非匹配边)
			{
				lef[j] = i;//学生j与课程i匹配
				return true;
			}
		}
	}
	return false;
}
int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d", &p, &n);
		int m, temp;
		memset(W, 0, sizeof(W));
		memset(lef, 0, sizeof(lef));
		for (int i = 1; i <= p; i++)
		{
			scanf("%d", &m);
			for (int j = 1; j <= m; j++)
			{
				scanf("%d", &temp);
				W[i][temp] = 1;
			}
		}
		int sum = 0;
		for (int i = 1; i <= p; i++)
		{
			memset(T, 0, sizeof(T));//这是递归路径,所以每次要更新
			if (match(i))//每次找到会增加一条匹配边
				sum++;
		}
		if (sum == p)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值