poj3041 Asteroids

题意:需要我们消除行星,每次只能消除一行或一列,所以把行星的x看作左结点,y看作右节点,匈牙利算法,因为x和y已经是匹配点的时候,就不用再消除一次了

AsteroidsTime Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
AC代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#define MAXN 505
bool map[MAXN][MAXN], vis[MAXN];
int match[MAXN];
int n, k;

bool dfs( int u)
{
    int v;
    for( v = 1; v <= n; v ++)
        if( map[u][v] && !vis[v])
        {
            vis[v] = true;
            if( match[v] == -1 || dfs( match[v]))
            {
                match[v] = u;
                return true;
            }
        }
        return false;
}

int MaxMatch()
{
    int u, ret = 0;
    memset( match, -1, sizeof match);
    for( u = 1; u <= n; u ++)
    {
        memset( vis, false, sizeof vis);
        if( dfs(u)) ret ++;
    }
    return ret;
}

int main()
{
    while( scanf( "%d%d", &n, &k) == 2)
    {
        int x, y;
        memset( map, false, sizeof map);
        for( int i = 1; i <= k; i ++)
        {
            scanf( "%d%d", &x, &y);
            map[x][y] = true;
        }
        int ans = MaxMatch();
        printf( "%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值