Meteor Shower POJ - 3669

Meteor Shower POJ - 3669 
Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input
* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

Output
* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input
4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output
5
 

代码:

#include<iostream>
#include<queue>
#include<algorithm>

using namespace std;

int maps[302][302];
int moves[] = { 1,-1,0,0,0 };
int movess[] = { 0,0,1,-1,0 };

struct Meteor
{
    int x, y, t;
    Meteor(int xx, int yy, int tt) { x = xx; y = yy; t = tt; }
    Meteor() {};
};

queue<Meteor> q;
int last;
bool visit[301][301] = { false };

int solve()
{
    q.push(Meteor(0, 0, 0));
    while (!q.empty())
    {
        Meteor node = q.front();
        for (int i = 0; i<4; i++)
        {
            int xx = node.x + moves[i];
            int yy = node.y + movess[i];
            
            if (0 <= xx && 0 <= yy && node.t + 1<maps[xx][yy] && !visit[xx][yy])
            {
                visit[xx][yy] = true;
                if (last<maps[xx][yy]) return node.t + 1;
                q.push(Meteor(xx, yy, node.t + 1));
            }
        }
        q.pop();
    }
    return -1;
}

int main()
{
    memset(maps, 0x7f, sizeof(maps));
    int m;
    cin>>m;
    for (int i = 0; i<m; i++)
    {
        int x, y, t;
        cin>>x>>y>>t;
        if (last<t) last = t;
        for (int j = 0; j<5; j++)
        {
            int nx = x + moves[j];
            int ny = y + movess[j];
            if (0 <= nx && nx<301 && 0 <= ny && ny<301)
                maps[nx][ny] = min(maps[nx][ny], t);
        }
    }
    cout << solve() << endl;
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值