Meteor Showerpoj3669

Meteor Shower
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15192 Accepted: 4003
Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

  • Line 1: A single integer: M
  • Lines 2..M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

Output

  • Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output

5
Source

USACO 2008 February Silver

题意:
给m个炸弹,炸弹在第t秒钟会在(x,y)处爆炸,爆炸会波及周围的四个点。求离(0,0)最近的没有被爆炸波及的点。
思路:
简单的bfs即可。求出每个点爆炸的时间。不会爆炸的点时间设置为0x3f3f3f3f
注意:
题目数据比较坑,可能有同一个点爆炸好多次,取最小的那个时间。然后数据范围尽量开大一点,测试数据到302,不要只开到300

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

int m;
int time[500][500];
bool tar[500][500];
bool vis[500][500];
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
int N=320;

struct data
{
    int x,y,cost;

}st;
bool ok(int x,int y)
{
    if(x<0||x>=N||y<0||y>=N)
        return 0;
    return 1;
}
void ini(int x,int y,int z,int tar[][500])
{
    tar[x][y]=min(z,tar[x][y]);
    for(int i=0;i<4;i++)
    {
        int xx,yy;
        xx=x+dx[i];
        yy=y+dy[i];
        if(ok(xx,yy))
        {
            tar[xx][yy]=min(tar[xx][yy],z);
        }
    }
}
queue<data >que;

void bfs()
{
    st.x=st.y=st.cost=0;
    while(!que.empty())
        que.pop();
    memset(vis,0,sizeof vis);
    que.push(st);
    vis[st.x][st.y]=1;
    while(!que.empty())
    {
        data now=que.front();
        que.pop();
      //  printf("now.x:%d  now.y:%d\n",now.x,now.y);
        if(time[now.x][now.y]==0x3f3f3f3f)
        {   //puts("ahha");
           // printf("x:%d  y:%d\n",now.x,now.y);
            printf("%d\n",now.cost);
            return ;
        }

        for(int i=0;i<4;i++)
        {
            data ne=now;
            ne.x=now.x+dx[i];
            ne.y=now.y+dy[i];
            ne.cost=now.cost+1;
           // printf("ok:%d    ne.cost%d   time[%d][%d]:%d   vis:%d\n",ok(ne.x,ne.y),ne.cost,ne.x,ne.y,time[ne.x][ne.y],vis[ne.x][ne.y]);
          //  printf("%d  %d  %d\n",ok(ne.x,ne.y),ne.cost<time[ne.x][ne.y],vis[ne.x][ne.y]==0);
            if(ok(ne.x,ne.y)&&ne.cost<time[ne.x][ne.y]&&vis[ne.x][ne.y]==0)
            {
               // puts("haha");
                vis[ne.x][ne.y]=1;
                que.push(ne);
            }
        }
    }
    puts("-1");
}
int main()
{
    while(scanf("%d",&m)!=EOF)
    {
        memset(time,0x3f3f3f3f,sizeof time);
        for(int i=0;i<m;i++)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            time[x][y]=min(time[x][y],z);
         //   printf("x:%d  y:%d  z:%d\n",x,y,z);
            ini(x,y,z,time);
        }
        bfs();

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值