POJ - 3669 Meteor Shower(bfs)

点击打开题目链接

Meteor Shower
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 19992Accepted: 5189

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5

Sample Output

5

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   

Go Back  

To top



题目大意:

有一场流星雨要降临,给定流星雨落得位置和时间,最初Bessie在坐标原点上,求她到达安全地点所需要的时间。流星雨落下来后除去落到当前坐标,还会覆盖相邻上下左右四个点。

思路:

每分钟更新地图的方法显然不可取,所以最初令地图上所有点为-1,之后改为时间值,大于这个时间值才可行。构图完后再用宽搜BFS做即可。

附上AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>

using namespace std;
const int maxn=300+5;
int map[maxn][maxn];
int dx[]={0, 0, 1, 0, -1},dy[]={0, 1, 0, -1, 0};
int px,py,pt;
int M;

struct nodes{
    int x, y, time;
};

int bfs(){
    if(map[0][0]==-1)return 0;
    else if(map[0][0]==0) return -1;
    queue<nodes>pq;
    pq.push(nodes{0,0,0});
    while(!pq.empty()){
        nodes p=pq.front(), temp;
        pq.pop();
        for(int i=0;i<5;i++){
            temp.x=p.x+dx[i];
            temp.y=p.y+dy[i];
            temp.time=p.time+1;
            if(temp.x>=0&&temp.x<maxn&&temp.y>=0&&temp.y<maxn){
                if(temp.time<map[temp.x][temp.y]){
                    map[temp.x][temp.y]=temp.time;
                    pq.push(temp);
                }
                else if(map[temp.x][temp.y]==-1){
                    return temp.time;
                }
            }
        }
    }
    return -1;
}

int main(){
    while(~scanf("%d",&M)){
        memset(map,-1,sizeof(map));
        for(int i=0;i<M;i++){//构图
            scanf("%d%d%d",&px,&py,&pt);
            for(int i=0;i<5;i++){
                int nx=px+dx[i];
                int ny=py+dy[i];
                if(nx>=0&&nx<maxn&&ny>=0&&ny<maxn){
                    if(map[nx][ny]>pt||map[nx][ny]==-1)
                        map[nx][ny]=pt;
                }
            }
        }
        printf("%d\n",bfs());   
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值