hdu1241---Oil Deposits(简单搜索)

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

 

Sample Input

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

 

Sample Output

0

1

2

2

 

 解题思路:

从第一个@开始进行搜索,不停的把邻接的@换成*。这样依次dfs后就可以将第一个@相邻的@都替换成*了,然后记一次数,然后再次从下一个@开始dfs直到所有的@都被换成*,那么进行的dfs的次数就是答案了。复杂度位O(m*n)。

具体解释见代码注释。

AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
char a[105][105];
int n,m;
void dfs(int x,int y)
{
	a[x][y]='*'; //将其标记为*
	for(int dx=-1;dx<=1;dx++)
		for(int dy=-1;dy<=1;dy++){ //遍历移动的八个方向
			int nx=x+dx;
			int ny=y+dy;
			if(nx>=0&&nx<m&&ny>=0&&ny<n&&a[nx][ny]=='@') //判断是否在范围内且是油田
				dfs(nx,ny);//再从这个相邻的开始dfs
		}
	return ; //直到所有的相邻的都被标记,完成这一次dfs,即记录了一片相邻的油田
}
int main()
{
	while(~scanf("%d%d",&m,&n)){
		if(m==0||n==0)
			break;
		int sum=0;
		for(int i=0;i<m;i++)
			scanf("%s",a[i]);
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++){
				if(a[i][j]=='@'){
					dfs(i,j);
					sum++; //记录dfs的次数,即是答案
				}
			}
		printf("%d\n",sum);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值