浙江省赛2015 _ G - Lunch Time -> ZOJ - 3875

25 篇文章 0 订阅

水题
这道题比赛当时没有做出来。原因是 ends ,C++对ends的处理是在缓冲区插入 ‘\0’ 然后刷新,而不是空格,能输出空格是因为Windows对 ‘\0’ 默认的处理方式是输出一个空格,而linux下则不会有什么输出。即windows和linux对’\0’的处理方式不同,而本次测评OS为Linux,所以WA。以后 注意用 ” ” 。
题目:ZOJ 3878

The 999th Zhejiang Provincial Collegiate Programming Contest will be held in Marjar University. The canteen of Marjar University is making preparations for this grand competition. The canteen provides a lunch set of three types: appetizer, main course and dessert. Each type has several dishes with different prices for choosing.
Edward is the headmaster of Marjar University. One day, to inspect the quality of dishes, he go to the canteen and decides to choose a median set for his lunch. That means he must choose one dish from each of appetizers, main courses and desserts. Each chosen dish should at the median price among all dishes of the same type.
For example, if there are five dessert dishes selling at the price of 2, 3, 5, 10, 30, Edward should choose the dish with price 5 as his dessert since its price is located at the median place of the dessert type. If the number of dishes of a type is even, Edward will choose the dish which is more expensive among the two medians.
You are given the list of all dishes, please write a program to help Edward decide which dishes he should choose.
Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains three integers S, M and D (1 <= S, M, D <= 100), which means that there are S dishes of appetizer, M dishes of main course and D dishes of dessert.
Then followed by three parts. The first part contains S lines, the second and the last part contains M and D lines respectively. In each line of the three parts, there is a string and an integer indicating the name and the price of a dish. The name of dishes will only consist of non-whitespace characters with no more than 50 characters. The price of dishes are non-negative integers less than or equal to 1000. All dish names will be distinct.
Output
For each test case, output the total price of the median set, together with the names of appetizer, main course and dessert, separated by a single space.
Sample Input
2
1 3 2
Fresh_Cucumber 4
Chow_Mein 5
Rice_Served_with_Duck_Leg 12
Fried_Vermicelli 7
Steamed_Dumpling 3
Steamed_Stuffed_Bun 4
2 3 1
Stir-fried_Loofah_with_Dried_Bamboo_Shoot 33
West_Lake_Water_Shield_Soup 36
DongPo’s_Braised_Pork 54
West_Lake_Fish_in_Vinegar 48
Longjing_Shrimp 188
DongPo’s_Crisp 18

Sample Output
15 Fresh_Cucumber Fried_Vermicelli Steamed_Stuffed_Bun
108 West_Lake_Water_Shield_Soup DongPo’s_Braised_Pork DongPo’s_Crisp

思路:选择给定的早中晚饭的价格,奇数个就选中间的,偶数个就选中间两个较大的即可。

代码实现:

#include<bits/stdc++.h>
using namespace std;

int main(int argc, char const *argv[])
{
    int t;
    cin>>t;
    while(t--){
        pair<int ,string > dis[3][200]; 
        int smd[3];
        for(int i=0;i<3;i++)
            cin>>smd[i];
        for(int i=0;i<3;i++){
            for(int j=0;j<smd[i];j++)
                cin>>dis[i][j].second>>dis[i][j].first;
            sort(dis[i],dis[i]+smd[i]);
        }
        int ans = 0;
        string str[3];
        for(int i=0;i<3;i++){
            int tmp = smd[i]/2;
            ans += dis[i][tmp].first;
            str[i] = dis[i][tmp].second;
        }
        cout<<ans<<" ";
        for(int i=0;i<3;i++){
            cout<<str[i];
            if(i!=2) cout<<" ";
        }
        cout<<endl;
    }
    return 0;
}

小结:这题很伤,Debug很长时间,对C++ 的本质理解不够深入,一直以为ends就是C++ 里的空格,不想被一直用的Windows坑了,以后要增加对Linux系统的了解。感谢:https://www.cnblogs.com/MrLJC/p/3749782.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值