个人赛(D - 防ak HDU - 1535 )最短路(SPFA)

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 
 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop. 

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers. 

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

比赛时就发现是道原题,并且知道是最短路,但是…………emmmm,没写出来…………。

题意:

 p个车站,q条公交路线(可以理解为道路),接下来q行每行输入三个整数a,b,c;表示a站到b站有一条公交路线,车费为c。

求从车站1到其余车站并且返回到车站1所花费的最小费用。

 

思路:建两次图,求两次spfa,正向建次图,反向建次图;正向建图求车站1到其余车站的最短路;反向建图:比如样例二中车站

2到车站1的最短路就是2->4->1,如果反向建图就是求1->4->2 对不对,就是这个思路。

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <cmath>
#include <iostream>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define ll long long
using namespace std;
#define inf 0x3f3f3f3f
int head[1000005],cnt,dis[1000005],uu[1000005],vv[1000005],ww[1000005];
bool vis[1000005];int n,m;
struct node
{
    int u,v,w,next;
}se[1000001*4];
void add(int u,int v,int w)
{//连边
    se[cnt]=(node){u,v,w,head[u]};
    head[u]=cnt++;
}
void init()
{
    cnt=0;
    mem(head,-1);
    mem(dis,inf);
    mem(vis,0);
}
ll spfa(int s)
{
    queue<int>q;
    q.push(s);
    vis[s]=1;//vis[i]=1表示i点在队列q中,反之不在
    dis[s]=0;//dis[i]表示i点到源点的最短距离
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=head[u];i!=-1;i=se[i].next)
        {
            int v=se[i].v;//下一站点
            int w=se[i].w;//u点到v点的权值即花费
            if(dis[v]>dis[u]+w)
            {
                dis[v]=dis[u]+w;
                if(!vis[v])
                {
                    q.push(v);
                    vis[v]=1;
                }
            }
        }
    }
    ll sum=0;
    for(int i=1;i<=n;i++)//求车站1到其余车站的最小费用和
    {
        sum+=dis[i];
    }
    return sum;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&uu[i],&vv[i],&ww[i]);
            add(uu[i],vv[i],ww[i]);
        }
        ll sum=spfa(1);//第一次spfa求出车站1到其余车站的最小费用和
        init();//重新建图
        for(int i=0;i<m;i++)
        {
            add(vv[i],uu[i],ww[i]);//反向连图
        }
        sum+=spfa(1);//再次spfa并加到sum上面
        printf("%lld\n",sum);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值