Wormholes

9 篇文章 0 订阅
                     Wormholes 

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题目大意:约翰的牧场有N个区域,这些区域直接有一些道路连接,另外约翰还发现一些虫洞,可以让他从S到E时间倒退T秒,问他能否走过若干路径之后回到原点看到出发前的自己?

思路:把带有虫洞的边看做负权边,若能看到出发前的自己即能找到负权环,用spfa判断一个节点重复n次以上出现在队列中即出现负权环。

code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f

int map[505][505];
int first[1000010],dis[1000010];
int next[1000010],point[1000010],w[1000010],q[1000010];
int cnt[1000010];
bool f[1000010];
int n,m,ww,tot;

void add(int x,int y,int c)
{
    tot++;
    w[tot]=c;
    next[tot]=first[x];
    first[x]=tot;
    point[tot]=y;
}

bool spfa(int s)
{
    memset(dis,INF,sizeof(dis));
    memset(f,0,sizeof(f));
    memset(cnt,0,sizeof(cnt));
    int l,r,x,y,k;
    l=100000;
    r=l;
    dis[s]=0;
    q[l]=s;
    f[s]=true;
    while (l<=r)
     {
         x=q[l];
         if(cnt[x] >= n)
            return false;
         l++;
         k=first[x];
         f[x]=false;
         while(k!=0)
           {
              y=point[k];
              if(dis[y]>dis[x]+w[k])
                {
                    dis[y]=dis[x]+w[k];
                    if (!f[y])
                      {
                          cnt[y]++;
                          if (dis[y]<dis[q[l]])
                            {
                                l--;
                                q[l]=y;
                                f[y]=true;
                            } else
                            {
                                r++;
                                q[r]=y;
                                f[y]=true;
                            }
                      }
                }
              k=next[k];
           }
     }
    return true;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        tot = 0;
        memset(first,0,sizeof(first));
        scanf("%d%d%d",&n,&m,&ww);
        int x,y,z;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            add(x,y,z);
            add(y,x,z);
        }
        for(int i=1;i<=ww;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            add(x,y,-z);
            add(x,y,-z);
        }
        if(spfa(1))
           printf("NO\n");
        else
           printf("YES\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值