《算法竞赛入门经典》中有代表性的编程思想

《算法竞赛入门经典》(第2版) 习题2-6 排列(permutation) 
用1,2,3,…,9组成3个三位数abc,def和ghi,每个数字恰好使用一次,要求abc:def:ghi=1:2:3。按照“abc def ghi”的格式输出所有解,每行一个解。提示:不必太动脑筋。(编程思想:用数组作为标志位来判断数字是否已经被使用过

#include <iostream>
#include <stdio.h>
#include <math.h>

using namespace std;
int is_valid_number(int num, int array[])
{
	int x, y, z;
	x = num / 100;
	y = num / 10 % 10;
	z = num % 10;
	if (x == y || y == z || x == z || array[x] || array[y] || array[z]) {
		// Digit used
		return 0;
	}
	array[x] = array[y] = array[z] = 1;
	return 1;
}
int main()
{
	int array[10];
	array[0] = 1;
	for (int checked_num = 123; checked_num < 329; checked_num++)
	{
		for (int i = 1; i < 10; i++)
			array[i] = 0;
		if (is_valid_number(checked_num, array)
			&& is_valid_number(checked_num * 2, array)
			&& is_valid_number(checked_num * 3, array))
		{
			cout << checked_num << " " << checked_num * 2 << " " << checked_num * 3 << endl;
		}
	}

	system("pause");
	return 0;
}

《算法竞赛入门经典》(第2版) 程序3-3 蛇形填数

蛇形填数。在n×n方阵里填入1,2,…,n×n,要求填成蛇形。例如,n=4时方阵为:

 10 11 12  1
  9  16 13  2
  8  15 14  3
  7   6   5   4

上面的方阵中,多余的空格只是为了便于观察规律,不必严格输出。n≤8。(编程思想:先找到填数规则,即从第一行最后一列开始按照下——左——上——右——下的顺序填数,在未满足转向条件时按照既定方向一直填下去,所以这里主要使用while循环加上转向条件判断

#include<stdio.h>
#include<string.h>
#define maxn 20
int a[maxn][maxn];
int main()
{
	int n, x, y, tot = 0;
	scanf("%d", &n);
	memset(a, 0, sizeof(a));
	tot = a[x = 0][y = n - 1] = 1;
	while (tot < n*n)
	{
		while (x + 1 < n && !a[x + 1][y]) a[++x][y] = ++tot;
		while (y - 1 >= 0 && !a[x][y - 1]) a[x][--y] = ++tot;
		while (x - 1 >= 0 && !a[x - 1][y]) a[--x][y] = ++tot;
		while (y + 1 < n && !a[x][y + 1]) a[x][++y] = ++tot;
	}
	for (x = 0; x < n; x++)
	{
		for (y = 0; y < n; y++) printf("%3d", a[x][y]);
		printf("\n");
	}
	return 0;
}

《算法竞赛入门经典》(第2版) 程序3-4 竖式问题

竖式问题。找出所有形如abc*de(三位数乘以两位数)的算式,使得在完整的竖式中,
所有数字都属于一个特定的数字集合。输入数字集合(相邻数字之间没有空格),输出所有
竖式。每个竖式前应有编号,之后应有一个空行。最后输出解的总数。具体格式见样例输出
(为了便于观察,竖式中的空格改用小数点显示,但所写程序中应该输出空格,而非小数
点)。
样例输入:
2357
样例输出:
<1>
..775
X..33
-----
.2325
2325.
-----
25575
The number of solutions = 1

编程思想:把所有要查找的数用sprintf以字符串的形式存在一个字符数组里,遍历这个数组,用字符串查找函数strchr查找是否存在

#include<stdio.h>
#include<string.h>
int main()
{
	int count = 0;
	char s[20], buf[99];
	scanf("%s", s);
	for (int abc = 111; abc <= 999; abc++)
		for (int de = 11; de <= 99; de++)
		{
			int x = abc*(de % 10), y = abc*(de / 10), z = abc*de;
			sprintf(buf, "%d%d%d%d%d", abc, de, x, y, z);
			int ok = 1;
			for (int i = 0; i < strlen(buf); i++)
				if (strchr(s, buf[i]) == NULL) ok = 0;
			if (ok)
			{
				printf("<%d>\n", ++count);
				printf("%5d\nX%4d\n-----\n%5d\n%4d\n-----\n%5d\n\n", abc, de, x, y, z);
			}
		}
	printf("The number of solutions = %d\n", count);
	return 0;
}

《算法竞赛入门经典》(第2版) 例题3-5 生成元

如果x加上x的各个数字之和得到y,就说x是y的生成元。给出n(1≤n≤100000),求最小生成元。无解输出0。例如,n=216,121,2005时的解分别为198,0,1979。(编程思想:对于数量有限且输入和输出一一对应的问题,可以先生成对应表,再用查表法得出对应解,可以极大提升程序运行速度

#include<stdio.h>
#include<string.h>
#define maxn 100005
int ans[maxn];
int main() {
	int T, n;
	memset(ans, 0, sizeof(ans));
	for (int m = 1; m < maxn; m++) {
		int x = m, y = m;
		while (x > 0) { y += x % 10; x /= 10; }
		if (ans[y] == 0 || m < ans[y]) ans[y] = m;//ans[y]对应的生成元是m
	}
	scanf("%d", &T);
	while (T--) {
		scanf("%d", &n);
		printf("%d\n", ans[n]);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值