hdu 5224

hdu 5224 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5224


Tom and paper


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 952    Accepted Submission(s): 584




Problem Description
There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 


Input
In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper.
T≤10,n≤109
 


Output
For each case, output a integer, indicates the answer.
 


Sample Input
3
2
7
12
 


Sample Output
6
16
14
 


Source
BestCoder Round #40
 
题目大意是给你一个面积,喊你求最小的周长(长宽都是整数)。
暴力可过。

代码:

<span style="font-size:18px;">#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int ans[100000009];

int main()
{
    int T;

    scanf("%d", &T);
    while(T--)
    {
        int area;
        scanf("%d", &area);
        int cnt = 0;
        for(int i=1; i*i<=area; i++)
        {
            if(area % i == 0)
            {
                ans[cnt++] = i*2 + (area/i)*2;
            }
        }
        sort(ans, ans+cnt);
        printf("%d\n", ans[0], ans[cnt-1]);
    }


    return 0;
}</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值