HDU5842——Lweb and String(CCPC网络赛第11题)

16 篇文章 0 订阅
3 篇文章 0 订阅

Lweb and String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 266    Accepted Submission(s): 176



Problem Description
Lweb has a string S .

Oneday, he decided to transform this string to a new sequence.

You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing).

You need transform every letter in this string to a new number.

A is the set of letters of S , B is the set of natural numbers.

Every injection f:AB can be treat as an legal transformation.

For example, a String “aabc”, A={a,b,c} , and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3.

Now help Lweb, find the longest LIS which you can obtain from S .

LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)
 

Input
The first line of the input contains the only integer T,(1T20) .

Then T lines follow, the i-th line contains a string S only containing the lowercase letters, the length of S will not exceed 105 .
 

Output
For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.
 

Sample Input
  
  
2 aabcc acdeaa
 

Sample Output
  
  
Case #1: 3 Case #2: 4
 

解:开始看到LIS以为是递增最大子序列,用dp和二分写完之后,WA,后来才发现,直接统计不同字母数量就可以了。给出LIS对于此题的代码,以及只统计不同字母数量的代码。

dp+二分,n*log(n):
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm> 
#include<string.h>
using namespace std;
char str[100010];
int number[100010];
int dp[100010];
int insert(int num,int end)
{
    int begin=0;
    while(begin<end-1){
        int mid=(begin+end)/2;
        if(dp[mid]>=num)
            end=mid;
        else
            begin=mid;
    }    
    dp[begin+1]=num;
    return begin+1;
}
int main()
{
    int T;
    int i,j;
    int count=0;
    scanf("%d%*c",&T);
    while(T--)
    {
        memset(number,0,sizeof(number));
        count++;
        gets(str);
        int leng = strlen(str);
        for(int i=0;i<100010;i++){
            dp[i]=99999;
        }
        for(int i=0;i<leng;i++)
            number[i]=str[i]-'a'+1;
        sort(number,number+leng); 
        for(int i=0;i<leng;i++){
            insert(number[i],leng-1);
        }
        printf("Case #%d: %d\n",count,insert(99999,leng)-1);
        for(int i=0;i<100010;i++){
            dp[i]=99999;
        }
    }
    return 0;
}

直接统计不同字母数量,n:
#include<stdio.h>
#include<string.h>

int a[27];
char b[100010];

int main()
{
    int t;
    int count=1;
    scanf("%d",&t);
    getchar();
    while(t--){
        memset(a,0,sizeof(a));
        int x=0;
        gets(b);
        int len=strlen(b);
        for(int i=0;i<len;i++){
            a[b[i]-'a']=1;
        } 
        for(int i=0;i<26;i++){
            if(a[i]){
                x++;
            }
        }
        printf("Case #%d: %d\n",count++,x);
    }
    
    return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值