POJ1850——Code

18 篇文章 0 订阅
Code
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9492 Accepted: 4542

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character). 

The coding system works like this: 
• The words are arranged in the increasing order of their length. 
• The words with the same length are arranged in lexicographical order (the order from the dictionary). 
• We codify these words by their numbering, starting with a, as follows: 
a - 1 
b - 2 
... 
z - 26 
ab - 27 
... 
az - 51 
bc - 52 
... 
vwxyz - 83681 
... 

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code. 

Input

The only line contains a word. There are some constraints: 
• The word is maximum 10 letters length 
• The English alphabet has 26 characters. 

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55

Source



解:

字典序问题。

详解请看:字典序问题

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

long long c(int n,int m)
{
	long long num=1;
	for(int i=1;i<=m;i++)
	{
		num=num*(n-i+1);
		num/=i;
	}
	return num;
}
int main()
{
	char a[11];
	while(cin>>a)
	{
		long long sum=1;
		int len=strlen(a);
		for(int i=1;i<len;i++)  
        {  
            if(a[i]<=a[i-1])  
            {  
                printf("0\n");
				return 0;  
            }  
        }  
		for(int i=1;i<len;i++)
			sum+=c(26,i);
		int start = 0;
		for(int i=0;i<len;i++)
		{
			for(int z=start;z<a[i]-'a';z++)
			{
				sum+=c(26-z-1,len-i-1);
			}
			start=a[i]-'a'+1;
		}
		printf("%I64d\n",sum);
		memset(a,0,sizeof(a));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值