约瑟夫环

约瑟夫环

约瑟夫问题
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic Discuss

Problem Description

n个人想玩残酷的死亡游戏,游戏规则如下:

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。

Input

输入n和m值。

Output

输出胜利者的编号。

Example Input

5 3

Example Output

4

Hint

第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀

代码块

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
using namespace std;
typedef struct node
{
    int data;
    struct node * next;
}node;
node *creat(int n) //建立循环链表
{
    node *head,*tail,*p;
    int i;
    p=(node *)malloc(sizeof(node));
    p->next=NULL;
    head=p;
    tail=p; 
    p->data=1;
    for(i=2;i<=n;i++)
    {
        p=(node *)malloc(sizeof(node));
        p->next=NULL;
        p->data=i;
        tail->next=p;
        tail=p;
    }
    tail->next=head;
    return head;
}
void search(node *head,int n,int m)
{
    node *q,*p;
   int num=0;
   int count=0;
   q=head;
   while(q->next!=head)
     q=q->next;
   while(count<n-1)
   {
      p=q->next;
      num++;
      if(num%m==0)
      {
          q->next=p->next;
          free(p);
          count++;
      }
      else
          q=p;
   }
   printf("%d\n",q->data);
}
int main()
{
     node * head;
    int n,m;
    scanf("%d %d",&n,&m);
    head=creat(n);
    search(head,n,m);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值