nyoj991-Registration system(map)

Registration system
时间限制:1000 ms | 内存限制:65535 KB
难度:2

描述

A new e-mail service "Berlandesk" is going to be opened in Berland in the near future.
 The site administration wants to launch their project as soon as possible, that's why they
 ask you to help. You're suggested to implement the prototype of site registration system. 
The system should work on the following principle.
Each time a new user wants to register, he sends to the system a request with his name.
 If such a name does not exist in the system database, it is inserted into the database, and 
the user gets the response OK, confirming the successful registration. If the name already 
exists in the system database, the system makes up a new user name, sends it to the user 
as a prompt and also inserts the prompt into the database. The new name is formed by the
 following rule. Numbers, starting with 1, are appended one after another to name (name1,
 name2, ...), among these numbers the least i is found so that namei does not yet exist in
 the database.

输入
The first line contains number n (1 ≤ n ≤ 105). The following n lines contain the requests to the system. Each request is a non-empty line, and consists of not more than 1000 characters, which are all lowercase Latin letters.
输出
Print n lines, which are system responses to the requests: OK in case of successful registration, or a prompt with a new name, if the requested name is already taken.
样例输入

4
abacaba
acaba
abacaba
acab

样例输出

OK
OK
abacaba1
OK

题目意思大概就是要做一个注册系统,判断用户名是否重复,若不重复则输出OK,否则输出这个用户名并且后面跟上数字1,2,3…代表第几次重复。
用到STL中的map。

代码如下:

#include<iostream>
#include<map>

using namespace std;

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        map<string,int>m;
        while(n--)
        {
            string a;
            cin>>a;
            if(!m.count(a))
            {
                m[a]++;
                printf("OK\n");
            }
            else
            {
                m[a]++;
                cout<<a<<m[a]-1<<"\n";
            }
        }
    }
    return 0;
}

补充一些map简单的常用知识:

(1)map的遍历:

map<string,int>::iterator it; //定义一个迭代指针
for(it=m.begin();it!=m.end();++it)
{
    cout<<it->first<<it->second<<"\n";
}

it->first是索引键值,it->second是值。

(2)map的一些常用方法:

clear()  // 删除所有元素
count() //返回指定元素出现的次数
empty() //如果map为空则返回true
remove() //删除一个元素
find() //查找一个元素
insert() //插入元素
size() //返回map中元素的个数
swap() //交换两个map
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值