NYOJ 991 Registration system(map简单应用)

OK
    
    
描述

A new e-mail service "Berlandesk" is going to be opened in Berland in the near future.

 The site administration wants to launch their project as soon as possible, that's why they

 ask you to help. You're suggested to implement the prototype of site registration system. 

The system should work on the following principle.

Each time a new user wants to register, he sends to the system a request with his name.

 If such a name does not exist in the system database, it is inserted into the database, and 

the user gets the response OK, confirming the successful registration. If the name already 

exists in the system database, the system makes up a new user name, sends it to the user 

as a prompt and also inserts the prompt into the database. The new name is formed by the

 following rule. Numbers, starting with 1, are appended one after another to name (name1,

 name2, ...), among these numbers the least i is found so that namei does not yet exist in

 the database.

输入
The first line contains number n (1 ≤ n ≤ 105). The following n lines contain the requests to the system. Each request is a non-empty line, and consists of not more than 1000 characters, which are all lowercase Latin letters.
输出
Print n lines, which are system responses to the requests: OK in case of successful registration, or a prompt with a new name, if the requested name is already taken.
样例输入
4
abacaba
acaba
abacaba
acab
样例输出
OK
OK
abacaba1
OK
来源



/*使用STL的映射容器map使此题解起来很简单*/


#include<iostream>  
#include<map>  //增加的头文件
using namespace std;  
int main()  
{  
    int n;  
    string str;  
    map<string,int>mymap;  //容器,自解:输入数据为字符串,输出数据为整型常量。
    cin>>n;  
    while(n--)  
    {  
        cin>>str;  
        if(mymap[str])  //检测容器中是否含有,含有返回值为1,否则为0.
        cout<<str<<mymap[str]<<endl;  
        else  
        cout<<"OK"<<endl;
        mymap[str]++;  
    }  
    return 0;  

}  


当然,这道题也可以用普通做法来做,只不过较为麻烦,思路为建立一个字符串数组,然后每输入一个字符串,就在已保存的字符串数组中检测是否存在(注:创建一个记录数量的数组),然后选择输出。

ac代码:

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
int main()
{
    string str[100];
    int a[1000],j,n,i;
    cin>>n;
    memset(a,0,sizeof(a));
    i=0;
    while(n--)
    {
        string s;
        cin>>s;
        int k=0;
        for(j=0;j<i;j++)
        {
            if(s==str[j])
            {
                a[j]++;//计数数组
                k=1;
                cout<<s<<a[j]<<endl;
            }
        }
        if(k==0)
        {
            cout<<"OK"<<endl;
            str[i++]=s;//储存字符串
        }
    }
    return 0;
} 




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值