题目描述
如题,给定一棵有根多叉树,请求出指定两个点直接最近的公共祖先。
输入输出格式
输入格式:
第一行包含三个正整数N、M、S,分别表示树的结点个数、询问的个数和树根结点的序号。
接下来N-1行每行包含两个正整数x、y,表示x结点和y结点之间有一条直接连接的边(数据保证可以构成树)。
接下来M行每行包含两个正整数a、b,表示询问a结点和b结点的最近公共祖先。
输出格式:
输出包含M行,每行包含一个正整数,依次为每一个询问的结果。
输入输出样例
输入样例
5 5 4
3 1
2 4
5 1
1 4
2 4
3 2
3 5
1 2
4 5
输出样例
4
4
1
4
4
解题分析:
树剖LCA板子…
不过其与树剖的dfs和查询有异曲同工之妙, 推荐阅读
隔壁ShadyPi dalao的Tarjan LCA 算法 ( O(N+M) O ( N + M ) ) %%% 前往阅读
代码如下:
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
#define MX 500005
#define gc getchar()
#define R register
#define W while
#define IN inline
namespace LCA
{
int topf[MX], fat[MX], dep[MX], head[MX], son[MX], cnt, tot[MX];
struct Edge
{
int to, nex;
}edge[MX << 1];
IN void addedge(const int &from, const int &to)
{
edge[++cnt] = (Edge){to, head[from]};
head[from] = cnt;
}
int dfs1(int now, int fa, int dp)
{
dep[now] = dp;
fat[now] = fa;
tot[now] = 1;
int ms = -1;
for (R int i = head[now]; i; i = edge[i].nex)
{
if(edge[i].to == fa) continue;
tot[now] += dfs1(edge[i].to, now, dp + 1);
if(ms < tot[edge[i].to]) son[now] = edge[i].to, ms = tot[edge[i].to];
}
return tot[now];
}
void dfs2(int now, int grand)
{
topf[now] = grand;
if(!son[now]) return;
dfs2(son[now], grand);
for (R int i = head[now]; i; i = edge[i].nex)
{
if(edge[i].to == fat[now]) continue;
if(edge[i].to == son[now]) continue;
dfs2(edge[i].to, edge[i].to);
}
}
IN int query(int x, int y)
{
int prex = x, prey = y;
W (topf[x] != topf[y])
{
if(dep[topf[x]] < dep[topf[y]]) prey = y, y = fat[topf[y]];
else prex = x, x = fat[topf[x]];
}
if(dep[x] < dep[y]) return x;
return y;
}
}
using namespace LCA;
int main()
{
int num, a, b, root, q;
scanf("%d%d%d", &num, &q, &root);
for (R int i = 1; i < num; ++i)
{
scanf("%d%d", &a, &b);
addedge(a, b);
addedge(b, a);
}
dfs1(root, 0, 1);
dfs2(root, root);
for (R int i = 1; i <= q; ++i)
{
scanf("%d%d", &a, &b);
printf("%d\n", query(a, b));
}
return 0;
}