博弈——Nim or not Nim?

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap. 

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not. 

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
Sample Input
2
3
2 2 3
2
3 3
Sample Output
Alice
Bob


题意:在传统的nim博弈上加了一个新操作,可以将一堆石头分解成两小堆石头。。。

思路:

数据范围太大,只能先打表找规律。。。

打表代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>
#include <algorithm>
#include <vector>
#include <stack>
#define INF 0x3f3f3f3f
#pragma comment(linker, "/STACK:102400000,102400000")
using namespace std;
const int maxn=50;
int sg[maxn];
int get_sg(int x)
{
    if(sg[x]!=-1)
        return sg[x];
    bool vis[maxn]={false};
    for(int i=0; i<x; i++)
        vis[get_sg(i)]=true;
    for(int i=1; i<x; i++)
        vis[get_sg(i)^get_sg(x-i)]=true;   //标记分解的两个堆的sg值异或的状态
    for(int i=0; ; i++)
        if(!vis[i])
        {
            sg[x]=i;
            break;
        }
    return sg[x];
}
int main()
{
    memset(sg, -1, sizeof(sg));
    for(int i=1; i<maxn; i++)
    {
        sg[i]=get_sg(i);
        printf("sg[%d]=%d\n", i, sg[i]);
    }
    return 0;
}


打完表一看,规律很明显:

除4余1和除4余2的sg值为本身,除4余3的是本身+1,能整除的为本身-1


AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>
#include <algorithm>
#include <vector>
#include <stack>
#define INF 0x3f3f3f3f
#pragma comment(linker, "/STACK:102400000,102400000")
using namespace std;
int n;
int get_sg(int x)
{
    switch(x%4)
    {
    case 1:
    case 2: return x;
    case 3: return x+1;
    case 0: return x-1;
    }
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            int x;
            scanf("%d", &x);
            ans^=get_sg(x);
        }
        if(ans)
            printf("Alice\n");
        else
            printf("Bob\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值