HDU3032 Nim or not Nim? 博弈

Nim or not Nim?
单击666传送
Problem Description

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.

Input

Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], …., s[N-1], representing heaps with s[0], s[1], …, s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)

Output

For each test case, output a line which contains either “Alice” or “Bob”, which is the winner of this game. Alice will play first. You may asume they never make mistakes.

Sample Input

2
3
2 2 3
2
3 3

Sample Output

Alice
Bob

最后一句我们假设他们很聪明一看就是博弈论的问题,但是这道题数据量太大了,通过样例大致可以看出他在描述计算SG的值去完成一些balabala的比较,好难的。还是找找规律好了。
自己没有找到唉,靠的百度,但是自己还是错了好几次,总是打错
但是这个异或的意思还是要懂的,就是将博弈的每一个堆当成子游戏的意思。
这道题本意就是分石子

#include <stdio.h>
int la(int n){
    if(n%4==0)
    return n-1;
    if(n%4==3)
    return n+1;
    return n;
} 
int main()
{int t;
scanf("%d",&t);
while(t--){
    int n,f=0;
    scanf("%d",&n);    
    while(n--){
        int a;
        scanf("%d",&a);
        f^=la(a);
    }
    if(f)
    printf("Alice\n");
    else
    printf("Bob\n");
}

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值