HDU 5289 Assignment(思维)

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4775    Accepted Submission(s): 2218


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test,output the number of groups.
 

Sample Input
 
 
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
 
 
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]

题意:给你n个数(n<=1e5),给你k,求有多少个连续的区间,满足区间内任意两数差的绝对值不超过k。

对于任意一个区间[l,r]如果是合法的,那么如果r>l,则[l+1,r]也是合法的。因此维护两个优先队列即可。

代码:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=100010;
const ll mo=1e9+7;
int n,m,k,x,y,f;
int a[maxn],sum[maxn],you[maxn];
int c[maxn],pos[maxn],l[maxn],r[maxn];
ll ans,ct,cnt,tmp,flag;
int ma1,ma2,mi1,mi2;
struct nod
{
    int id;
    int v;
    nod(){}
    nod(int x,int y){id=x;v=y;}
    bool operator<(nod a)
    const{
        return v<a.v;
    }
};
struct node
{
    int id;
    int v;
    node(){}
    node(int x,int y){id=x;v=y;}
    bool operator<(node a)
    const{
        return v>a.v;
    }
};
int main()
{
    int T,cas=1;
    scanf("%d",&T);
    {
        while(T--){
            scanf("%d%d",&n,&k);
            priority_queue<nod>p;//da
            priority_queue<node>q;//xiao
            f=0;
            //memset(c,0,sizeof(c));
            ans=0;f=0;
            for(int i=0;i<n;i++)scanf("%d",&a[i]);
            int j=0;
            nod n1(j,a[j]); p.push(n1);
            node n2(j,a[j]);q.push(n2);
            for(int i=0;i<n;)
            {
                while(j+1<n)
                {
                    if(max(p.top().v,a[j+1])-min(q.top().v,a[j+1])<k)
                    {
                        j++;
                        nod n1(j,a[j]); p.push(n1);
                        node n2(j,a[j]);q.push(n2);
                    }
                    else break;
                }
                ans+=(ll)(j-i+1);
                i++;
                if(i==n) break;
                while(!p.empty()&&p.top().id<i) p.pop();
                while(!q.empty()&&q.top().id<i) q.pop();
                if(j<i)
                {
                    j++;
                    nod n1(j,a[j]); p.push(n1);
                    node n2(j,a[j]);q.push(n2);
                }
            }
        printf("%lld\n",ans);
       // if(flag) puts("YES"); else puts("NO");
    }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值