HDU 5326 Work (树形dp入门)

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2457    Accepted Submission(s): 1430


 

Problem Description



It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 

 

 

Input

There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n

 

 

Output

For each test case, output the answer as described above.

 

 

Sample Input

 

7 2 1 2 1 3 2 4 2 5 3 6 3 7

 

 

Sample Output

 

2

题意:给你一个有向树,求子树节点总个数等于k的节点个数。

思路:统计子树个数是树形dp入门吧。。。废话不多说

代码:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=10010;
int n;
int m,k,q,f;
int dp[maxn],head[maxn];
int c[maxn];
int ct,cnt,tmp,flag,ans;
int vis[maxn];
struct node
{
    int to,nex,w;
}a[maxn];
void init()
{
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    cnt=0;
}
void add(int u,int v,int w)
{
    a[cnt].to=v;
    a[cnt].w=w;
    a[cnt].nex=head[u];
    head[u]=cnt++;
}
int dfs(int u)
{
    dp[u]=0;
    for(int i=head[u];i!=-1;i=a[i].nex)
    {
        int v=a[i].to;
        dp[u]+=dfs(v);
    }
    return dp[u]+1;
}
int main()
{
    int T,cas=1;
   while(scanf("%d %d",&n,&m)!=EOF)
   {
       init();
       for(int i=0;i<n-1;i++)
       {
           int x,y;
           scanf("%d %d",&x,&y);
           add(x,y,0);
           vis[y]=1;
       }
       for(int i=1;i<=n;i++)
       if(!vis[i])dfs(i);
       ans=0;
       for(int i=1;i<=n;i++)
       if(dp[i]==m)ans++;
       printf("%d\n",ans);
   }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值